Post Reply 
Can not update firmware with the latest connectivity kit
06-14-2017, 05:18 AM (This post was last modified: 06-14-2017 05:21 AM by wangchong01.)
Post: #1
Can not update firmware with the latest connectivity kit
Hello,
The latest connectivity kit can't update the firmware except 10637.It will get stuck at the "waiting for connection...". When I pulled out my calculator,it started and gave me an error "Update failed".I have updated my Windows to 15063,so is this the reason that the connectivity dead?I have flashed my calculator with a three-party firmware and it can only enter the recovery mode(v16).I have tried connect the calculator with recovery mode, but the connectivity kit did not give me the dialog to update the firmware,so I can't flash my calculator back. Then what should I do?
I have tried the three versions of the connectivity kit in 2016,but it didn't help.
Find all posts by this user
Quote this message in a reply
06-14-2017, 07:25 AM
Post: #2
RE: Can not update firmware with the latest connectivity kit
Hi,

That is most definitively odd. While officially Rip'Em has your standard disclaimer about warranty voiding and bricking calculators, unofficially there's no way it can mess up the recovery mode (it does not overwrite BXCBOOT0.BIN or whatever the 256 KiB area at the beginning of flash is called these days and first thing Rip'Em does is enabling write-protection for that area in the flash controller).

I'll try to reproduce this when I get back from work.
Find all posts by this user
Quote this message in a reply
06-14-2017, 11:06 AM
Post: #3
RE: Can not update firmware with the latest connectivity kit
But how can I flash my calculator back?My calculator could be flashed when I terminated the calculator 2 months ago,but I can't do it now.
Find all posts by this user
Quote this message in a reply
06-14-2017, 04:50 PM
Post: #4
RE: Can not update firmware with the latest connectivity kit
So I've dusted off my HP Prime and did the following operations:
  • update from official firmware version 10077 to official firmware version 10637 with the new method ;
  • update from official firmware version 10637 to Rip'Em dcf427 with recovery ;
  • update from Rip'Em dcf427 to official firmware version 10637 with recovery.
All three firmwares worked perfectly with no issues, so I don't think you've bricked your calculator but merely have flashing issues with the official recovery mode.

Do the following operations:
  • remove the battery ;
  • close the HP Prime Connectivity Kit ;
  • put back the original firmware in the relevant directory (download it from ftp://ftp.hp.com/pub/calculators/Prime/ if needed) ;
  • hold down the SYMB button ;
  • plug in your HP Prime to your computer with a USB cable ;
  • open the HP Prime Connectivity Kit.

At this point the HP Prime Connectivity Kit should prompt you to update the firmware.

I am still not sure why Rip'Em did not work on your calculator. Perhaps you've made a mistake while building/flashing my firmware? (after all, Rip'Em is still a hacked-together proof of concept not suitable for daily use).
Find all posts by this user
Quote this message in a reply
06-15-2017, 04:28 AM
Post: #5
RE: Can not update firmware with the latest connectivity kit
I have tried other calculators but none of them could be flashed in this computer.I failed to flash any firmware just after I had updated my windows to 1703.Have you tried flashing the firmware with windows 10 1703 version? I think the problem may due to the operating system because the computer can't recorgnize my calculator as a storage though there was a device called "USB storage device" after I plugged the calculator to my computer.
Find all posts by this user
Quote this message in a reply
06-15-2017, 01:24 PM
Post: #6
RE: Can not update firmware with the latest connectivity kit
All I can suggest is trying another USB port, reinstalling the HP Connectivity Kit and/or trying another computer. I am actually not familiar at all with the HP Prime from the angle of a "normal" everyday user since its capabilities far exceeds my modest needs as a CS student, so I'm probably not the most qualified to help you out with these issues.
Find all posts by this user
Quote this message in a reply
06-15-2017, 07:36 PM
Post: #7
RE: Can not update firmware with the latest connectivity kit
This is a long standing bug with the CK and USB 3 compatibility on some computers.
Either use a USB 2.0 port or by a USB 3 to USB 2 adapter. That worked for me.
Find all posts by this user
Quote this message in a reply
06-16-2017, 12:36 AM
Post: #8
RE: Can not update firmware with the latest connectivity kit
(06-15-2017 07:36 PM)John Colvin Wrote:  Either use a USB 2.0 port or [buy] a USB 3 to USB 2 adapter.

Since USB 3.0 is backward compatible with USB 2.0, anyone selling a USB 3 to USB 2 adapter is ripping you off. Any USB 2.0 hub will do the trick.
Find all posts by this user
Quote this message in a reply
06-16-2017, 04:36 AM
Post: #9
RE: Can not update firmware with the latest connectivity kit
I installed a WIndows7 to my computer and revived my calculator yesterday. SmileI think it may due to the windows 10 system does not support the calculator device.BUT the firmware didn't work either.I have compiled the firmware with "ubuntu in windows" and "real" ubuntu,but the calculator remained to be blackscreened. Can you send me the firmware compiled in your computer so I can know whether it is because of my compiler or library version.
The files compiled by my computer is attached,and the version of my compiler is as below:
Copyright (C) 2013 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


Attached File(s)
.zip  ripem-master.zip (Size: 62.51 KB / Downloads: 3)
Find all posts by this user
Quote this message in a reply
06-16-2017, 06:24 PM
Post: #10
RE: Can not update firmware with the latest connectivity kit
There you go:
.zip  PRIME_OS.ROM.zip (Size: 21.85 KB / Downloads: 2)

I built this binary on a Debian Stretch with arm-none-eabi-gcc 5.4.1.
Find all posts by this user
Quote this message in a reply
06-16-2017, 06:40 PM
Post: #11
RE: Can not update firmware with the latest connectivity kit
I took a look at your PRIME_OS.ROM with a hex editor and there's nothing inside (the header is there, but there's no firmware and payloads are empty). Also, your ELF executables and your static libraries are all empty shells.

I have no idea how that happened, but there's something really fishy with your development environment.
Find all posts by this user
Quote this message in a reply
06-20-2017, 05:18 AM
Post: #12
RE: Can not update firmware with the latest connectivity kit
I'm using the ubuntu in windows instead of the real ubuntu, but the compiler is all installed by the commmand in the "readme". I have tried installing a gcc 6.3.0 but it doesn't help because "make" use the old gcc instead of the new one. Should I use the new gcc or a real ubuntu system?
Find all posts by this user
Quote this message in a reply
06-20-2017, 07:30 AM (This post was last modified: 06-20-2017 07:30 AM by toml_12953.)
Post: #13
RE: Can not update firmware with the latest connectivity kit
(06-20-2017 05:18 AM)wangchong01 Wrote:  I'm using the ubuntu in windows instead of the real ubuntu, but the compiler is all installed by the commmand in the "readme". I have tried installing a gcc 6.3.0 but it doesn't help because "make" use the old gcc instead of the new one. Should I use the new gcc or a real ubuntu system?

Try this:

Code:
sudo apt-get update

then

Code:
sudo apt-get install build-essential

Those commands will make sure you have the latest development environment.

Tom L
...other than that, Mrs. Lincoln, what did you think of the play?
Find all posts by this user
Quote this message in a reply
06-20-2017, 07:44 AM
Post: #14
RE: Can not update firmware with the latest connectivity kit
I'd say try with a Debian environment, or ditch WSL and use a virtual machine. Either WSL or Ubuntu is causing issues here and I'd blame Ubuntu first in case of doubt.

Just wondering, what's the version of Ubuntu you're using?

(06-20-2017 07:30 AM)toml_12953 Wrote:  Try this:

Code:
sudo apt-get update

then

Code:
sudo apt-get install build-essential

Those commands will make sure you have the latest development environment.

That would not explain why empty ELF shells were generated. We're using an ARM cross-compiler (arm-none-eabi) supplied by the packaging system for compiling the firmware, not the standard system compiler that targets Linux amd64 (presumably). The system toolchain does appear to work because the osrom2elf utility itself worked.
Find all posts by this user
Quote this message in a reply
06-21-2017, 09:05 AM
Post: #15
RE: Can not update firmware with the latest connectivity kit
root@DESKTOP-LB29QVS:/mnt/z/ripem-master# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty
That's my ubuntu version,I think I should try a virtual machine to compile it because the apt-get install build-essential doesn't help.
Find all posts by this user
Quote this message in a reply
06-22-2017, 12:45 PM
Post: #16
RE: Can not update firmware with the latest connectivity kit
I ran tests inside LXC containers and I've found why it won't work on Ubuntu 14.04.

The Makefile macros I'm using do not work properly with GNU make 3.81: LIST_SRCS in particular returns nothing, hence why the generated PRIME_OS.ROM was empty. osrom2elf built properly because it does not use macros in its Makefile.

It does work under Ubuntu 16.04, which has GNU make 4.1, so building probably requires GNU Make >= 4.0.

WSL recently switched to Ubuntu 16.04 but pre-existing installations are not upgraded automatically. Either recreate your WSL installation (lxrun /uninstall; lxrun /install) or execute do-release-upgrade to update your Ubuntu installation to 16.04.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)