Post Reply 
HP41-CV beeps on powerup, but no display
04-17-2016, 08:16 PM (This post was last modified: 04-17-2016 08:23 PM by mfleming.)
Post: #1
HP41-CV beeps on powerup, but no display
I'm attempting to restore an HP-41CV (2113A01932). A rechargable battery pack had been left in the calculator and leakage had destroyed the battery contacts and damaged the flex connector contacts to the PCB.

The PCB trace contacts on the board showed some green crud that cleaned up nicely with DeoxIT. There was no loss of gold plating or copper trace, and no sign of corrosion anywhere else in the calculator. After replacing a corroded flex connector with a new Flex-PCB from Diego (thanks!) and a battery tray from Shapeways, pressing the power On button results in a short beep and no display.

I pressed the I/O block into the PCB body, using the long screws to insure alignment, and checked adjacent flex contacts for shorts. I don't seem to have any misalignment between the flex contacts and the PCB traces, but I haven't verified that all of them are in electrical contact with the PCB traces.

Before proceeding further I thought I'd ask for advice before I end up stripping the screw posts from repeated disassembly. The beep seems to indicate that power is getting there, so I wonder if it might be a known meaningful error indicator. Are there test points within the calculator that I might connect power to in order to verify operation with the calculator open? Suggestions, links to material, etc. would be greatly appreciated.

Thanks,
~Mark

Addendum: After removing the battery pack, about 1.3V remains on the contacts, and shorting the contacts does not immediately remove the residual voltage. It takes a while to drop below 0.5V. The unit stops beeping after a couple of power-up attempts, until the residual voltage finally decays.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)