Post Reply 
Problem with Laplace transform
01-18-2016, 11:58 AM
Post: #1
Problem with Laplace transform
Hi !

When i want to do a Laplace transform like :

Laplace(u(t),t,p) i want to have for the result : 1/p but didn't have this ...

And when i do ILaplace(1/p) i have for result : Dirac/p ...

What is the problem ? Ans how can i fix it ?

Thanks and have a Nice day !
Find all posts by this user
Quote this message in a reply
01-18-2016, 02:13 PM
Post: #2
RE: Problem with Laplace transform
Hi

Both the "laplace" and "ilaplace" functions have three parameters: expression, variable of the expression, and variable of the result. The last two variables are optional, but it looks like if you don't specify them, the calculator uses the variable x as the default variable.

With firmware 2015 6 17 (8151), you have the following results:

laplace(1): 1/x

laplace(1,t,p): 1/p

ilaplace(1/x): 1

ilaplace(1/p): Dirac(x)/p ---> wrong

ilaplace(1/p,p,t): 1

So, it seems that sometimes the two last variables are necessary, in order to get correct answers.

I hope this heps.
Find all posts by this user
Quote this message in a reply
01-18-2016, 03:09 PM
Post: #3
RE: Problem with Laplace transform
The default variable is x, therefore nothing is wrong.
Find all posts by this user
Quote this message in a reply
01-18-2016, 04:52 PM
Post: #4
RE: Problem with Laplace transform
You're right.

The case ilaplace(1/p) = Dirac(x)/p is correct because p is interpreted by the HP Prime as a constant.
Find all posts by this user
Quote this message in a reply
01-18-2016, 10:51 PM (This post was last modified: 01-18-2016 10:52 PM by Natoe.)
Post: #5
RE: Problem with Laplace transform
Thanks ! , but for the U(t) like in this exemple :

http://image.noelshack.com/fichiers/2016...-titre.png

U(t) on Hp prime = "1" because U(t) = 1/P and when i did : "ilaplace(1/p,p,t)" the result is "1"

So i did on the hp prime :"Laplace((1+(t-2)².1(t-2),t,p) for the exercice and the result is wrong or not the same ...

And thanks for your answer !
Find all posts by this user
Quote this message in a reply
01-19-2016, 08:21 AM
Post: #6
RE: Problem with Laplace transform
I guess that by U(t) you mean the step function. In that case you need to use the HP Prime function Heaviside().

The step function at t=0 is Heaviside(t), and the step function at other values, say t=2, is Heaviside(t-2).

Using this function you get:

laplace(Heaviside(t),t,p) = 1/p

laplace(Heaviside(t-2),t,p) = e^(-2*p)/p

laplace(Heaviside(t)+(t-2)^2*Heavisede(t-2),t,p) = (p^2+2*e^(-2*p)) / p^3
Find all posts by this user
Quote this message in a reply
09-29-2020, 05:31 PM
Post: #7
RE: Problem with Laplace transform
I am having some issues that seem similar to this but I just cant get it to work. I am trying to get the Laplace function to work on my calculator but I keep running into errors. The only one I am able to get working is "laplace(1)".
laplace(1)->1/x
ilplace(1/x)->±∞
laplace((5/(16*x^2+10*x)))->Undef
"laplace(5/(16*x^2+10*x),x,s) -> Error: Bad Argument Value"


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
09-29-2020, 07:32 PM
Post: #8
RE: Problem with Laplace transform
This is what I get in my G1 Prime, running software version 2.1.14425 (2020 01 16)
   

Josep Mollera. HP PRIME, HW: C, SW: 2.1.14425 (2020 01 16).
Find all posts by this user
Quote this message in a reply
09-29-2020, 10:42 PM
Post: #9
RE: Problem with Laplace transform
(09-29-2020 05:31 PM)Grayhek Wrote:  I am having some issues that seem similar to this but I just cant get it to work. I am trying to get the Laplace function to work on my calculator but I keep running into errors. The only one I am able to get working is "laplace(1)".
laplace(1)->1/x
ilplace(1/x)->±∞ ...

I'm guessing that you have a zero stored in 'x'. Try again after purge(x).

<0|ɸ|0>
-Joe-
Visit this user's website Find all posts by this user
Quote this message in a reply
09-29-2020, 10:51 PM
Post: #10
RE: Problem with Laplace transform
(09-29-2020 10:42 PM)Joe Horn Wrote:  
(09-29-2020 05:31 PM)Grayhek Wrote:  I am having some issues that seem similar to this but I just cant get it to work. I am trying to get the Laplace function to work on my calculator but I keep running into errors. The only one I am able to get working is "laplace(1)".
laplace(1)->1/x
ilplace(1/x)->±∞ ...

I'm guessing that you have a zero stored in 'x'. Try again after purge(x).

purge(x) returns "No such variable x"
But when I run x it does return a number such as 0 or whatever is stored. I cleared all of the data on the calculator and then it worked but I deleted all my programs which I don't like. Purge does not seem to find or clear 'x'.
Find all posts by this user
Quote this message in a reply
09-30-2020, 09:52 PM
Post: #11
RE: Problem with Laplace transform
(09-29-2020 10:51 PM)Grayhek Wrote:  purge(x) returns "No such variable x"
But when I run x it does return a number such as 0 or whatever is stored. I cleared all of the data on the calculator and then it worked but I deleted all my programs which I don't like. Purge does not seem to find or clear 'x'.

purge() only works on CAS variables.

To clear Home variables, use the memory manager (Shift B) — User Variables, select, then delete or backspace.

Cambridge, UK
41CL/DM41X 12/15C/16C DM15/16 71B 17B/BII/bII+ 28S 42S/DM42 32SII 48GX 50g 35s 30b/WP34S Prime G2
& Casios, Rockwell 18R :)
Find all posts by this user
Quote this message in a reply
10-01-2020, 10:13 AM
Post: #12
RE: Problem with Laplace transform
laplace((5/(16*x^2+10*x))) is infinity because the integral is singular at x=0. I believe you want to compute ilaplace((5/(16*x^2+10*x)))
Find all posts by this user
Quote this message in a reply
10-02-2020, 01:03 PM
Post: #13
RE: Problem with Laplace transform
(09-29-2020 10:51 PM)Grayhek Wrote:  
(09-29-2020 10:42 PM)Joe Horn Wrote:  I'm guessing that you have a zero stored in 'x'. Try again after purge(x).

purge(x) returns "No such variable x"
But when I run x it does return a number such as 0 or whatever is stored. I cleared all of the data on the calculator and then it worked but I deleted all my programs which I don't like. Purge does not seem to find or clear 'x'.

Sounds like the difference between 'X' and 'x' is not well understood, not to mention the difference between Home and CAS. If purge(x) says "No such variable x" then you CANNOT get a value by executing x (lowercase letter x). But you will ALWAYS get a value after executing X (uppercase letter X) because X is a permanently existing Home variable which always contains a real number, and cannot be purged. It's not intended for symbolic math work, which is done in CAS using lowercase variables.

<0|ɸ|0>
-Joe-
Visit this user's website Find all posts by this user
Quote this message in a reply
10-03-2020, 12:22 AM
Post: #14
RE: Problem with Laplace transform
hah! I didn't even notice the significance of the particular variable it was, sigh; thanks Joe.

Cambridge, UK
41CL/DM41X 12/15C/16C DM15/16 71B 17B/BII/bII+ 28S 42S/DM42 32SII 48GX 50g 35s 30b/WP34S Prime G2
& Casios, Rockwell 18R :)
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)