Post Reply 
I need help finding complex roots
03-28-2020, 04:59 PM
Post: #1
I need help finding complex roots
Hi all. I'm very new to HP Prime and I've tried to do my research about my question, but everything I try doesn't work.
I'm trying to find roots of a Quadratic formula. I can't find out how to do it.

Example:
x^2+2x+5=0
this is the answer i'm hoping to see from the calculator: x = -1 + 2i or x = -1 - 2i

I have tried Toolbox->Polynomial->Find Roots (and it gave me -2 as an answer?)
Toolbox->Solve->Solve, Zeros, Complex Solve, Complex Zeros

Nothing is giving me the answer I want.
What am I missing?
Why would proot only give me one answer?

Thanks so much for your time!
Find all posts by this user
Quote this message in a reply
03-28-2020, 05:39 PM
Post: #2
RE: I need help finding complex roots
I get the correct answer. Can you post a screenshot of how that happened?

   
Find all posts by this user
Quote this message in a reply
03-28-2020, 06:23 PM
Post: #3
RE: I need help finding complex roots
Are you using [CAS] for this?
Find all posts by this user
Quote this message in a reply
03-29-2020, 05:36 PM
Post: #4
RE: I need help finding complex roots
Hi, under CAS, csolve should also have worked fine (in addition to proof). If you set "Use I" (to factor polynomials) in CAS settings, then solve also works fine under the latest version.
Find all posts by this user
Quote this message in a reply
03-29-2020, 07:09 PM (This post was last modified: 03-29-2020 07:11 PM by rrpalma.)
Post: #5
RE: I need help finding complex roots
(03-28-2020 04:59 PM)freyabelle Wrote:  Hi all. I'm very new to HP Prime and I've tried to do my research about my question, but everything I try doesn't work.
I'm trying to find roots of a Quadratic formula. I can't find out how to do it.

Example:
x^2+2x+5=0
this is the answer i'm hoping to see from the calculator: x = -1 + 2i or x = -1 - 2i

I have tried Toolbox->Polynomial->Find Roots (and it gave me -2 as an answer?)
Toolbox->Solve->Solve, Zeros, Complex Solve, Complex Zeros

Nothing is giving me the answer I want.
What am I missing?
Why would proot only give me one answer?

Thanks so much for your time!

Make sure you have "Complex" enabled on the CAS settings. I just tried your equation, and yes, you do get an empty set as an answer if Complex is not enabled. But you do get your expected, correct answers if you set the Complex flag.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: