Post Reply 
HELP on TI-59 Module
10-15-2019, 08:48 AM
Post: #1
HELP on TI-59 Module
Hi to everyone,

Recently I bought two modules on ebay: Statistics and Real Estate.

When I checked the contacts of the two modules I realized that they were oxidized, I tried to scratch them to remove the oxide.

When I tried the Real Estate module, when I executed the 2nd PGM 01 operation, a fading C appeared on the left.

Same behavior also with the Statistics module.

Once I was able to run the diagnostics on the Real Estate module in a positive way by looking at a number 3 on the display (module number).

I tried to compare the contacts of the Master Module with the contacts of the RE and ST modules, I noticed that in the latter the contacts are smaller.

The Master Module works correctly.

Oxidation and smaller contacts could cause the problem of not reading the form?

I enclose photo contact forms.

I thank you in advance for your suggestions.

   

   
Find all posts by this user
Quote this message in a reply
10-15-2019, 01:27 PM
Post: #2
RE: HELP on TI-59 Module
(10-15-2019 08:48 AM)Doctor_Jacek Wrote:  Hi to everyone,

Recently I bought two modules on ebay: Statistics and Real Estate.

When I checked the contacts of the two modules I realized that they were oxidized, I tried to scratch them to remove the oxide.

When I tried the Real Estate module, when I executed the 2nd PGM 01 operation, a fading C appeared on the left.

Same behavior also with the Statistics module.

Once I was able to run the diagnostics on the Real Estate module in a positive way by looking at a number 3 on the display (module number).

I tried to compare the contacts of the Master Module with the contacts of the RE and ST modules, I noticed that in the latter the contacts are smaller.

The Master Module works correctly.

Oxidation and smaller contacts could cause the problem of not reading the form?

I enclose photo contact forms.

I thank you in advance for your suggestions.

The dimmed C means a program is running. How long does the manual say the operation should take? If you don't have the manuals, you can get them here:

Datamath.org

Do the modules pass their diagnostic?

Code:
2nd
PGM 01
SBR =

A single number should be displayed and not flashing. If you have a PC-100 or 100A printer attached, the name of the module should be printed along with the same number shown in the display.

Tom L

If the First Presbyterian Church is nicknamed First Pres,
why isn't the First Methodist Church nicknamed First Meth?
Find all posts by this user
Quote this message in a reply
10-15-2019, 02:26 PM
Post: #3
RE: HELP on TI-59 Module
Hi Toml,

If you look at the pictures the Master Module contacts are bigger than the statistics module, I think this is the problem.

In fact, selecting only 2nd PGM 01 appears a vanishing C, this means that it does not load the program.

Retrying several times both with the Statistics module and the Real Estate module, without completely closing the support, I managed to make the values appear:
RE module 2nd PGM 01 SBR = -> 3
ST module 2nd PGM 01 SBR = -> 2

This confirms that CROMs are working ..

Unfortunately the situation is not definitive because when the CROM slot is closed the calculator does not read the modules.

I wanted to know if any of the Ti-59 / T58c users have encountered a similar problem on the CROM contacts.

Thanks
Find all posts by this user
Quote this message in a reply
10-22-2019, 01:21 AM
Post: #4
RE: HELP on TI-59 Module
My TI-58C would sometimes act strange when I put the Master Module in. Sometimes it would run programs, sometimes it would act strange or even lock up. I found that gently bending the contacts on the calculator's main board up a little helped the module make better contact and work fine. Might bend them up gently, one at a time and see if that helps.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)