Post Reply 
[solved] Connectivity Kit (Mac) cannot see new Prime G2
09-26-2018, 02:43 PM (This post was last modified: 09-27-2018 11:20 PM by cdmackay.)
Post: #1
[solved] Connectivity Kit (Mac) cannot see new Prime G2
hi, would appreciate any help here, please.

My problem is that the Connectivity Kit on my Macbook cannot see my new Prime G2, when connected via USB.

I'm new to these waters; I've been a Casio-er for decades, currently using the CG50 with GIAC CAS plug-in, and the CP400.

Had been interested in trying the Prime, so I bought the new G2 model yesterday. Seems fantastic so far.

I thought it would be fun to try the Connectivity Kit, and also to put the new Beta firmware on the calculator.

I'm using a 2018 MacBook Pro, running MacOS 10.13.6.

It has Thunderbolt 3 (only). This provides USB 3 busses via USB-C sockets. Because it only has two of those TB3 ports, and they are also needed for power and display, I'm using a Thunderbolt 3 dock, which itself also provides USB 3 busses, to which I'm connecting the Prime.

I put the Prime G2 into Update mode with Reset pin and Symb, and connect via a USB cable.

The calculator knows it has been connected to something, since the on-screen instructions disappear (and then reappear if I unplug the cable).

The MBP can see the Prime, if I check the USB devices via System Information.

I then start the Connectivity Kit, but it doesn't see any calculators. [It does see the emulator, if I start that up on the laptop, but it doesn't see the USB-connected Prime]

The Prime G2 came with firmware 2.0.0.13725 (2018 04 26).

Am I doing something obviously wrong, or missing something important? What can I do to get more debugging info?


Here's some things I've tried:

• multiple known-good USB A – microB cables, including the one supplied with the Prime

• connected the cable both to the Thunderbolt 3 dock's USB 3 port, and also to that dock via an intervening downstream USB 2.0 hub, and also a downstream USB 3.0 hub. [I can't connect directly to the laptop since I don't have a USB-C to micro-B cable, and in any case both ports on the laptop are permanently in use]

• two versions of Connectivity Kit: 20180706 & Beta 20180917 [Do I need a version that matches the 20180426 on my Prime?]

• various combinations of starting the Connectivity Kit before and after connecting the Prime

• rebooting the laptop


any suggestions please, on what I might be missing, or how to collect more debug data?

thanks very much indeed.

===

edit: hmm, well all is now well.

I did various things, but I think reinstalling the CK from scratch is what fixed it.

Cambridge, UK
41CL, 12C/15C, DM15/16, 71B, 17B, 28S, DM42, 48GX, 17bII+, 50g (& newRPL), 35s, 30b (WP 34S), Prime G2
& Casios, Rockwell 18R :)
Find all posts by this user
Quote this message in a reply
07-03-2019, 02:58 PM
Post: #2
RE: [solved] Connectivity Kit (Mac) cannot see new Prime G2
Hi

I am facing the same problems with imac :

Indeed, my mac does not detect the physical calculator. I restarted, reinstalled the HP Connectivity Kit, nothing to do the machine is not detected.

This is the HP_Prime_Connectivity_Kit_20181016.dmg, normally adapted for my OS (version 10.14.5 (18F132)).

My 4 USB ports have been tested and work.

Thanks for your help
Find all posts by this user
Quote this message in a reply
07-03-2019, 10:36 PM (This post was last modified: 07-03-2019 10:38 PM by smp.)
Post: #3
RE: [solved] Connectivity Kit (Mac) cannot see new Prime G2
IIRC, there is a new Connection Kit that supports the new G2 Prime. The new CK has the ability to determine if it is connected to a G1 or G2 and handle the software update accordingly. The older CK cannot recognize the new G2 version, I think.

If you have a new G2 Prime, the first thing to do is update to the most up-to-date Connection Kit.

smp
Find all posts by this user
Quote this message in a reply
07-03-2019, 11:55 PM (This post was last modified: 07-03-2019 11:59 PM by cdmackay.)
Post: #4
RE: [solved] Connectivity Kit (Mac) cannot see new Prime G2
CK 2.1.14181 (2018 10 16) is the latest for MacOS, I believe; that’s what I have here.

And that’s working fine for me, just tested it. I start the CK, then plug in the Prime G2; the CK sees it after a few seconds. Doesn’t matter if the Prime is on or off when I connect it (if it’s off, connecting it turns it on).

same MacOS: 10.14.5 (18F132)

Cambridge, UK
41CL, 12C/15C, DM15/16, 71B, 17B, 28S, DM42, 48GX, 17bII+, 50g (& newRPL), 35s, 30b (WP 34S), Prime G2
& Casios, Rockwell 18R :)
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)