Post Reply 
29C & tea don't mix
11-09-2020, 11:42 PM
Post: #1
29C & tea don't mix
I've been using my 29C since purchased new in the late 70s however I am new to this forum. A few days ago Hurricane Hazel-Rah spilled my mug of chai onto the keyboard and for the first time in 40-some years my 29C is misbehaving. Thanks to Bernard/Panamatik for his suggestion about washing the 29C in an alcohol bath.

Just for the record here are the symptoms before the bath:
First let me say I have been running this 29C on AA Alkaline cells for years, ever since the OEM cells failed.

After initially opening the case and drying the tea from the innards I powered on the 29C. The display flashed and blinked (as if a drowning person clearing their lungs), showed one 0 on the left, one 0 in the 11th position, and the 12th flashing all segments. The 11th decimal point was flashing the Low Battery warning. The AAs were new, measuring 1.6v each.

As a result of various manipulations I discovered that (with the power switch ON) when I removed and replaced the battery the display would show a solid "Error". Clearing that with CLX resulted in the 29C behaving normally except for the Decimal Point doing its Low Battery blinking. All the keys and functions I tested worked as expected. However when power is turned OFF and ON the display is dead.

Then if I R&R the battery the display shows "Error" again and works ok when I CLX that. That sequence (including the Decimal Point doing its Low Battery blinking) is repeatable ad nauseam.

So the 29C works if I leave the power switch ON and remove the battery to turn off. To use the 29C I have to install the battery and CLX to get rid of the Error and ignore the blinking DP.

What's wrong? What needs repaired?

I have cleaned the battery connectors, tried new AA cells, tried a fine regulated variable bench supply. I have also had the three boards separated and cleaned all the connectors with "DeoxIT" All results the same.

This is where Bernard suggested the alcohol bath. That done and several hours of leaving the boards to dry I then found where there was grey powdery stuff between pin 1-4 of the ACT chip and the Anode and Cathode ICs. Brushed that away and the 29C starts normally and seems to work OK. Yeaaa!

Thanks to and most especially Thank You Bernard/Panamatik.

Tourists don't know where they've been.
Travellers don't know where they're going.
--Paul Theroux
Visit this user's website Find all posts by this user
Quote this message in a reply
11-10-2020, 01:34 AM
Post: #2
RE: 29C & tea don't mix
Welcome to the MoHPC Forum ajo; if you're a 29C user, I think you'll find it nice here. Smile

Thanks for taking the time to describe your problem, interim cleaning attempts, and then your ultimate victory. Detailed posts like this are very helpful for readers with similar problems and your careful and detailed explanation will surely encourage and help guide some of them to attempt the same techniques and hopefully achieve similar success.

Bernhard truly is magical and generous and is responsible for saving many hundreds of Woodstock (and now Spice) machines with his patient explanations of careful cleaning and repair techniques, and eventually all the way up to the ACT replacement and Low Power Repair Kits for machines that have been damaged beyond direct repair. All of my Woodstock machines operate perfectly today due to Bernhard's advice, direct service or replacement Low Power kits. He's indeed a brilliant and kind person, and I appreciate him every day.

--Bob Prosperi
Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)