Post Reply 
Python script caused prime reboot - beta 2021-4-27
04-29-2021, 07:50 PM (This post was last modified: 04-29-2021 08:09 PM by froehlic.)
Post: #2
RE: Python script caused prime reboot - beta 2021-4-27
(04-28-2021 09:45 PM)tcab Wrote:  After entering something like this script in
def mary():
    for i in range(5):
        print(i, f"{y} i={i}", end=" ")
and running it with
import main
the G1 Prime rebooted itself! After going back into the Python app I found that the contents of the script was gone. But the worst of it is that I can't run any Python programs anymore because even though is empty, going into numeric view always gives me the following error
>import main
Traceback (most recent call last)
  File "<stdin>", line 1, in <module>
ImportError: no module named 'main'
Anything I type into is cleared and lost when going from the Python editor into Python numeric mode, and the above error traceback appears.

Interestingly, if you say cancel when asked to re-import, then the contents of are not lost, but the error traceback still occurs.

I tried deleting and it gets recreated but the problem persists. I tried resetting the Python app on the G1 Prime, but that doesn't help either. I'm stuck!

I had exactly the same problem. The only solution: CFO-Reset, -> 4. FLS Utility -> Format C -> Reset and everything is clear but I could enter my Python code until the next error came.
My G1 was stable with the actual FW. But with your code I have also a problem. I get the trace back error and my is empty. Every new code will be cleared by changing to Num Console. But I had no reset. The last days I helped myself in saving Python App to another App and working with this one. As soon as I have this behavior, I delete my new Python App, save the original again and so on.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Python script caused prime reboot - beta 2021-4-27 - froehlic - 04-29-2021 07:50 PM

User(s) browsing this thread: 1 Guest(s)