Post Reply 
Android app of WP-34s/31s?
09-19-2021, 09:14 AM (This post was last modified: 09-26-2021 05:34 PM by Dirk E..)
Post: #29
RE: Android app of WP-34s/31s?
Hello Pablo,

adding to your to-do-list (that led me here) as a wish:
- display orientation (setting or fix to portrait for now?)
- clipboard support (copy paste number to/from X, maybe also strings, or even programs?)
- setting display permanently on vs. allow power-saving (is it actually permanently on?)

Quote:- Make calculator memory persistent between executions (DONE)
- Haptic/sound feedback on the keys
- Visual keypresses feedback
- Settings for the two above (sound volume, vibration strength)
- A way to store/load WP-34s (compiled) programs from the phone memory
- Realtime clock emulator
- Port the WP-34s assembler itself so programs can be loaded/stored in WP-34s mnemonics format (Examples at see README_ASM)
- Debugging display, showing the stack and/or registers
- Skins support

After I was very happy to have found your aWP32s 0.0.6 on 'play' and to have it installed, looking beautifully realistic and working smoothly at first glance on a Galaxy S8 with Android 9.0 (de-de), a few questions arose, though:
- When I accidently turned the device to landscape and back to portrait, I found the stack contents changed back to an earlier state (maybe it's a caching quirk provided by the Samsung UI?),
- I found no settings dialogue when I tried to find a setting to fix the display orientation to portrait - so I'd suppose the app should rather remain in portrait view, unless there will be a skin that supports landscape - and maintain it's registers unchanged... (I had also hoped I could have it full-screen with hidden status bar and soft-keys.)
- The introduction on 'play' did not tell that the link "source code" would get me nearer to the explanation why "STOPW" in X.FCN is replaced by "???" (realtime clock is 'to-do' yet), which also breaks the navigation-by-letter for anything after S - despite DATE and TIME giving correct results :-)
- When I had received my WP34s I found CAT* Lib quite populated, according the manual are details in the XROM trunk, and the programs are included in the firmware. I was a little puzzled to find Lib empty in awp34s. But I understand that the XROM is not part of the ported source (yet).
- So I found that there's also no I/O (by now) for numbers/strings or programs or status backups (or maybe virtually print to a text file) - it's on the to-do-list, but it should be mentioned in the introduction on 'play' also.

Beyond the described here I did not experience any crash or hang-up as reported by Didier and BINUBALL - I tried the given examples on both the S8 and an XCovery4s with Android 11 (SETEUR and Display ALL 3). Unfortunately I'm neither deep in Math nor coding (especially Android), so I can only report from my point as a user what I'd desire. (Once I found in a collection on Murphy's law: "Write an idiot-proof program, and only an idiot will use it..." ;-) We're learning by making mistakes, and a few learn also from the mistakes made by others ...)

All in all I'm glad to have this almost-WP34s now in my pocket and I'd be even more happy to see it live on and grow a little yet.

With the best wishes

*) Thanks to Pauli for the library link - after checking again Owner's manual page 72 and 73 about Flash and XROM I seem to better understand that XROM code is an internal part of the WP32s, and that what I found in my calculator's flash Library was an optional selection. D.

Finally I entered a first small program into aWP34s, and I stuck on the strange effect that I have to press [R/S] twice before the execution continues. I tried h [P/R] either immediately as well as after the first press of [R/S] in the loop - and I got the same line (immediately after the STOP) in the display. I tend to think it may be related to the realtime clock function - when I run X.FCN WHO on my WP34s, it automatically advances to the next line after briefly pausing. Not so on the aWP34s - here I have to press the DOWN arrow to advance. (And in my WP34s there's no Crystal installed, it does not show the X.FCN STOPW menu entry at all.) Btw. PSE 10 in place of STOP halts forever until I press any other key, like [h] or [DOWN], but not R/S (after R/S it shows "Stopped"). Although it may be related to my hardware - both smartphones are Samsung. Did anyone find anything similiar about [R/S] and PSE?

Simple loop:
001 LBL 'Stp'
002 1
003 ENTER^
004 +
005 STOP
006 RCL L
007 BACK 003
008 END

When I start with
instead of simply counting up I get:
2 R/S 2 R/S 3 R/S 3 R/S 4 ...
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
Android app of WP-34s/31s? - ArneStolti - 08-09-2017, 08:02 PM
RE: Android app of WP-34s/31s? - rprosperi - 08-09-2017, 09:30 PM
RE: Android app of WP-34s/31s? - Paul Dale - 08-10-2017, 03:16 AM
RE: Android app of WP-34s/31s? - odkq - 03-14-2021, 12:53 PM
RE: Android app of WP-34s/31s? - johanw - 03-14-2021, 02:52 PM
RE: Android app of WP-34s/31s? - odkq - 04-28-2021, 10:04 AM
RE: Android app of WP-34s/31s? - rprosperi - 03-14-2021, 04:49 PM
RE: Android app of WP-34s/31s? - rprosperi - 03-14-2021, 05:49 PM
RE: Android app of WP-34s/31s? - tuxfish - 03-14-2021, 06:18 PM
RE: Android app of WP-34s/31s? - cdmackay - 03-14-2021, 11:50 PM
RE: Android app of WP-34s/31s? - Gerald H - 03-15-2021, 04:50 AM
RE: Android app of WP-34s/31s? - BINUBALL - 03-15-2021, 06:46 AM
RE: Android app of WP-34s/31s? - Paul Dale - 03-15-2021, 06:57 AM
RE: Android app of WP-34s/31s? - odkq - 05-09-2021, 09:08 AM
RE: Android app of WP-34s/31s? - johanw - 05-21-2021, 11:10 PM
RE: Android app of WP-34s/31s? - BINUBALL - 06-17-2021, 12:15 PM
RE: Android app of WP-34s/31s? - Dirk E. - 09-19-2021 09:14 AM
RE: Android app of WP-34s/31s? - Paul Dale - 09-19-2021, 11:22 PM

User(s) browsing this thread: 1 Guest(s)