Post Reply 
Hp 41CX only displays something when pressed on
11-03-2019, 09:15 PM (This post was last modified: 11-04-2019 12:52 PM by Lode.)
Post: #4
RE: Hp 41CX only displays something when pressed on

Unfortunately it's not going too well with this.

I opened it up, and saw that there is 1 broken post: the right one on this picture:

That post is not just cracked in 2 halves, but also loose from the bottom:

But things are even worse now! By opening/closing the calculator multiple times, other things start breaking, namely these two plastic things for the battery contacts...

Also, before it used to operate normally when pressing the bottom, but now it was behaving very strangely, first it said memory lost, then after pressing alpha displayed this weird thing. What is it doing here???

That was the last thing it displayed. Ever since the battery contact fell out (with those new two plastic things broken shown above) and I try to reassemble it and push the sides hard, nothing gets displayed or nothing beeps anymore at all Sad

Basically, it's all brittle plastics and sensitive contacts galore! Anyone know any more stable ways to fix this? Anything that can be 3D printed? Or alternative ways of making good contacts? Do you think this one can be saved at all?

P.S. I also don't really know how to properly get materials like those particular exact types of screws but longer (in Europe)


EDIT: after another reopening/reclosing it can display things again (still only when pressing the bottom), but it's permanently stuck in USER mode, and the user key does not toggle it off. Even when removing and reinserting the batteries it keeps doing that. Could some of the top buttons be breaking too? Or is there some feature going on here that I don't know about, and it ended up randomly in this state when the weird stuff from the last screenshot above happened?

EDIT2: it actually seems to keep remembering numbers for a very long time after removing the batteries. Is a capacitor holding some power to retain memory? Any ideas how long it can keep memory without batteries?

EDIT3: backspace+on cleared that memory and now it behaves normal again so that's solved (other than that the bottom contacts still require pressing on it so I still need to succeed in that whole gluing thing...), but the user button still doesn't do anything, now user is permanently off. Could that one button also have a bad contact?
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Hp 41CX only displays something when pressed on - Lode - 11-03-2019 09:15 PM

User(s) browsing this thread: 1 Guest(s)