Post Reply 
G2 usb does not seem to work
09-18-2019, 05:13 AM
Post: #1
G2 usb does not seem to work
I can't get my G2 to connect to the connectivity kit. I have an older Prime and it connects fine but the G2 won't. When I connect the usb to the G2 it will charge but it will not connect. I've tried update mode and get nothing there either. I can't transfer anything between two calculators with the transfer cable. I have uninstalled and re-installed the connection kit and tried multiple cables and different computers, windows 7 and windows 10. The calculator itself works fine and it charges fine. When I bought it about 2 months ago I transferred the programs I use at work to it with the connection kit and had no problem. Now I wanted to transfer a newer version of one of the programs to it and I can't do it. I even tried resetting it to factory and that didn't work.

I would appreciate any help I can get.


CD Dodds
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
G2 usb does not seem to work - cdodds - 09-18-2019 05:13 AM
RE: G2 usb does not seem to work - cdodds - 09-18-2019, 01:50 PM
Use your warranty - striegel - 09-18-2019, 01:19 PM

User(s) browsing this thread: 1 Guest(s)