The Museum of HP Calculators

HP Forum Archive 20

[ Return to Index | Top of Index ]

Message #1 Posted by aj04062 on 12 May 2011, 8:14 p.m.

I think I'm getting carried away with this collecting stuff.

Had a friend of mine just pick up a 9810A. Hopefully it will arrive safely via UPS next week. Owner claimed one of the fuses is blown.

Hopefully that's it and can get placed into service again. I wonder what the folks in the office will think if this lands on my desk? They already think the 97 has neon tubes for a display.

Re: HP9810A
Message #2 Posted by Tony Duell on 13 May 2011, 4:49 a.m.,
in response to message #1 by aj04062

Unfortunately fuses don't blow for no good reason...

There are 2 fuses on the back of the 9810. One is 6A, and is in series with the mains input to everything, including the mains output sockets. The other is 1A (220/240V mains) or 2A (100/120V mains) and is in series with the feed to the mains transformer/fan only.

I hope you get the old fuse, you can tell a bit by examining it. If it's blown softly, then just replace it and try again. If it's shattered or blackened, you have more serious fault.

If the 6A fuse is blown, it's probable that either some device plugged into the output socket was resposible, or there's a fault in the mains input/switch circuitry. If the other fuse has blown, the fault could be in the power supply section of the machine or the mains transformer.

What I would do is remove the top cover, the keyboard, all the logic PCBs (you're working on the PSU, you don't want to damage anything if you make a mistake), the memory box, the printer, the PSU cover and the 3 boards under it. All that should remain in the machine is the rear panel (mains circuitry), the backplane, and the card reader mechanism (but this is not connected to anything now). Replace the fuse. Reconnect the keyboard mains switch cable (5 pin in-line connector), and turn on the switch. Do an insulation test between the mains live/neutral pins (strapped together) and the case. If that's the problem, check the mains filter, transformer, etc.

Now apply mains, preferably with a (filament) light bulb in series. A 100W bulb should be fine. The bulb should be dark (there's no load on the transformer after all). Teh fan should be running. Check the trasnformer secondary voltages at the PSU board edge connectors. Unplug the mains.

Check the rectifier diodes, smoothing capacitors, power transistors, etc on the PSU boards. Fit the PSU boards and plug the machine in, again with a light bulb in series if you can. Again the bulb should be dark (or at least very dim). If it's bright, you have a PSU problem. If the bulb is dark, check the PSU output voltages, there are testpoints for all of them apart from +5V on the PSU boards, check +5V on the backplane connector of one of the boards. When they're all OK, unplug the mains, reassemble the logic boards, and power up (with no light bulb this time). Hopefully the machine will then work, if not, you'll have a logic fault to trace.

You can download the HP service manual (mostly a boardswapper guide, but with PSU schematics) and full schematics for the machine from the Australian museum site. There should be an article on repairing this PSU in Datafile (HPCC journal) sometime, but I think you'll have to wait over a year for that.

Feel free to contact me about this fine machine

Re: HP9810A
Message #3 Posted by aj04062 on 13 May 2011, 7:01 a.m.,
in response to message #2 by Tony Duell

Thanks Tony,

I know, I know. Fuses are there for a reason.

I will follow your process and report on what I find.

[ Return to Index | Top of Index ]

Go back to the main exhibit hall