Post Reply 
pyILPER 1.4.0 with HP7470A emulation
11-05-2016, 06:41 PM (This post was last modified: 11-06-2016 06:27 AM by jsi.)
Post: #1
pyILPER 1.4.0 with HP7470A emulation
I published a beta version of the upcoming pyILPER version 1.4.0 on GitHUB. The most notable changes are:
  • Virtual HP-IL device HP7470A added
  • New device configuration facility to add or remove virtual HP-IL devices or to change their tab position.
If you like to give this version a try please consult the instructions in the description of the beta release.

The plotter should already produce quite reasonable results. Hence there are a some characteristics of the original device where I need test results of volunteers who have a working HP7470A (mine is malfunctioning). I attached a LIF image file with three HP-71 basic test programs:
  • CLIP: clipping and output of information
  • LOST1: operating the plotter outside the user coordinate range
  • LOST2: operating the plotter outside the plotter coordinate range
I'd be very happy if anybody could test whether the graphic and alphanumeric output of these programs match.

Regards
Joachim


Attached File(s)
.zip  plottest.zip (Size: 1.5 KB / Downloads: 13)
Find all posts by this user
Quote this message in a reply
11-05-2016, 11:03 PM
Post: #2
RE: pyILPER 1.4.0 with HP7470A emulation
just fantastic! a plotter to play with!
I've got a lot on my plate right now but can't resist to give this new coming version a try. I'm in the installation phase and share here some xrom files I added to the previous version to work with the CX rom. Also, on Mac OS I had to add a variable to the bash profile (~/.bash_profile) to make decomp41 find the roms definitions;
export LIFUTILSXROMDIR="/usr/local/share/lifutils/xroms/"
I don't have the plotter module but a NoV-64 is coming soon, I look foward...
thanks Joachim,
André


Attached File(s)
.zip  CX-xroms-for-lifutil.zip (Size: 2.2 KB / Downloads: 3)
Find all posts by this user
Quote this message in a reply
11-06-2016, 09:54 AM
Post: #3
RE: pyILPER 1.4.0 with HP7470A emulation
Congrats !!
My dream would be a complete system emulation on Android / iOS. For this we would need go41cx/go41cxt/i41cx+ to support the HP-Il. So far both authors have stated that the HP-Il is not so interesting to emulate for the 41 emulators, because mass storage is well covered with the HEPAX emulation (use the HEPAX modules as cheap internal disks !) and .raw files import, Printing is well covered with the 82143a emulation (with no port wasting), video interface is covered also with virtual printing (no practical use of 80 column or ESC sequences for the 41) and connection to external devices is not realistic for portable emulation. But... The 7470a device is the only one that could make the HP-Il emulation worthwhile !

What do you think ?

Cheers
Find all posts by this user
Quote this message in a reply
11-08-2016, 05:07 PM
Post: #4
RE: pyILPER 1.4.0 with HP7470A emulation
For some reason I can no longer get pyILPER to run. I tried reinstalling Miniconda and pyILPer and I get the following error:

C:\Users\Username\AppData\Local\Continuum\Miniconda3\Scripts\pyilper.bat\..\..\p​yt
hon.exe: can't open file 'C:\Users\Username\AppData\Local\Continuum\Miniconda3\Scr
ipts\pyilper-script.py': [Errno 2] No such file or directory


What did I do wrong?

Thanks, Dave
Find all posts by this user
Quote this message in a reply
11-08-2016, 07:12 PM
Post: #5
RE: pyILPER 1.4.0 with HP7470A emulation
It becomes difficult to reproduce what went wrong here. I suggest a clean new installation doing the following steps:

  1. issue a "conda info" from the command line and record the paths of the miniconda root environment and the config file
  2. deinstall miniconda from the windows control panel
  3. check whether the config file and all files of the root environment were deleted. If not, delete them manually.
  4. do a clean reinstall of miniconda and pyilper as specified in the installation instruction. You should download a fresh copy of
    miniconda for python3.5 first.


Regards,
Joachim
Find all posts by this user
Quote this message in a reply
11-09-2016, 03:03 AM
Post: #6
RE: pyILPER 1.4.0 with HP7470A emulation
(11-08-2016 07:12 PM)jsi Wrote:  It becomes difficult to reproduce what went wrong here. I suggest a clean new installation doing the following steps:

  1. issue a "conda info" from the command line and record the paths of the miniconda root environment and the config file
  2. deinstall miniconda from the windows control panel
  3. check whether the config file and all files of the root environment were deleted. If not, delete them manually.
  4. do a clean reinstall of miniconda and pyilper as specified in the installation instruction. You should download a fresh copy of
    miniconda for python3.5 first.


Regards,
Joachim

"conda info" informs me that my config file is at %HOME% but they were actually installed at %APPDATA%\pyilper.

I deleted the %HOME% variable and reinstalled Miniconda. "conda info" now reports my config file is at %USERPROFILE% as expected.

Same error message. I tried the installation on another computer with the same results. I have a drive that contains a previous installation and pyilper-script.py exists in the Scripts folder. Why is it missing from the recent installations as the error message reports?
Find all posts by this user
Quote this message in a reply
11-09-2016, 06:23 PM
Post: #7
RE: pyILPER 1.4.0 with HP7470A emulation
Maybe I have some of it figured out.
1. If I install using Miniconda it installs pyilper.bat in the Scripts folder which calls a nonexistant file and throws an error.
2. If I install using "python setup.py install" it installs pyilper.exe in the Scripts folder which takes precedence over the batch file and runs as expected.

I would have expected that the two procedures would produce the same results.

Dave
Find all posts by this user
Quote this message in a reply
11-09-2016, 06:53 PM
Post: #8
RE: pyILPER 1.4.0 with HP7470A emulation
I reproduced the error and found that something was messed up in the windows image of pyILPER 1.3.4 in the conda channel. I rebuilt and uploaded the packages and just tested that the missing bat file is now installed properly.

Running the setup.py is an other way to install pyILPER but this does not provide a clean deinstall oder update of new versions.

I apoligize for all trouble that caused.

Regards
Joachim
Find all posts by this user
Quote this message in a reply
11-09-2016, 08:01 PM
Post: #9
RE: pyILPER 1.4.0 with HP7470A emulation
Thanks, Joachim.

I look forward to your 2225 emulator. Smile

Dave
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)