Post Reply 
Error on virtual calculator and conn kit in Surface Pro 4
09-11-2016, 01:57 PM
Post: #1
Error on virtual calculator and conn kit in Surface Pro 4
Hello, I don't know if there is a known workaround but I cant run virtual calculator nor conn kit in my Surface Pro without getting to an error loop:

[Image: HP6tLhPtwF.png]

I remember something about this but I cant find it anymore :/ probably a dll is missing?

My website: erwin.ried.cl
Visit this user's website Find all posts by this user
Quote this message in a reply
09-12-2016, 01:58 PM
Post: #2
RE: Error on virtual calculator and conn kit in Surface Pro 4
This actually seems to be a conflict specific to surface units (v3/4 only) and has been reported by other surface users here since the update. I am guessing some sort of strange interaction with a specific hardware configuration unique to those models. It is being investigated.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
09-13-2016, 12:46 PM
Post: #3
RE: Error on virtual calculator and conn kit in Surface Pro 4
(09-12-2016 01:58 PM)Tim Wessman Wrote:  This actually seems to be a conflict specific to surface units (v3/4 only) and has been reported by other surface users here since the update. I am guessing some sort of strange interaction with a specific hardware configuration unique to those models. It is being investigated.

Oh, cool. Thanks for the answer. So basically they don't work at all with this pc?

I will take a look tonight

My website: erwin.ried.cl
Visit this user's website Find all posts by this user
Quote this message in a reply
09-15-2016, 06:22 PM
Post: #4
RE: Error on virtual calculator and conn kit in Surface Pro 4
Ok, the problem here seems to be that on certain devices (such as the surface) you could get back an HID node from the OS with 0 for vendor ID and Product ID (not sure exactly why this is the case). This case would cause the IO code in the emu/connkit to match the "named pipe" object - yet since it was flagged as a USB object it would try to initialize the usb object as a named pipe and cause.... . . . trouble.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
09-16-2016, 04:18 PM
Post: #5
RE: Error on virtual calculator and conn kit in Surface Pro 4
(09-15-2016 06:22 PM)Tim Wessman Wrote:  Ok, the problem here seems to be that on certain devices (such as the surface) you could get back an HID node from the OS with 0 for vendor ID and Product ID (not sure exactly why this is the case). This case would cause the IO code in the emu/connkit to match the "named pipe" object - yet since it was flagged as a USB object it would try to initialize the usb object as a named pipe and cause.... . . . trouble.

Cool, thanks for letting us know Tim.

My website: erwin.ried.cl
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)