Post Reply 
Problem with INPUT()command in RPN mode
05-14-2015, 01:27 PM (This post was last modified: 05-14-2015 01:27 PM by wawa.)
Post: #1
Problem with INPUT()command in RPN mode
Hello

I have a problem using the INPUT command in RPN mode : In a simple program like this :
Quote:EXPORT TEST()
BEGIN
INPUT({A,B});
END;

When I try to enter a negative number for A or B, Something strange happens : Single quotes are added in the edit line around my number and when I press OK, I have an Invalid Entry error. If I remove single quotes around my number, then it is OK. With positive numbers, no problem.

When I am in textbook or algebraic mode, I have no such problem.

I use the latest firmwrare (05/2015) but the problem was here also with the previous ones.
Find all posts by this user
Quote this message in a reply
05-14-2015, 06:09 PM
Post: #2
RE: Problem with INPUT()command in RPN mode
(05-14-2015 01:27 PM)wawa Wrote:  Im in textbook or algebraic mode, I have no such problem.

I use the latest firmwrare (05/2015) but the problem was here also with the previous ones.

Hello,

I think the issue is that you are using the minus operator key, instead of the negative key. It detects that you are typing an equation (similar to what you'd see if you typed [^]) and adds in the algebraic quote marks to avoid evaluation of your keypress. Unless I am remembering wron, the exact same thing happens on the 50g when you are in a dialog and press the subtraction key. You get '-' instead of just the -.

Try using the [+/-] key next to the ENTER key. Does that work for you?

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
05-14-2015, 08:31 PM (This post was last modified: 05-14-2015 08:34 PM by John Colvin.)
Post: #3
RE: Problem with INPUT()command in RPN mode
The problem with the INPUT command not accepting negative numbers also occurs with the +/- key. Hopefully, this will be fixed in the next firmware release.
Find all posts by this user
Quote this message in a reply
05-15-2015, 12:25 AM
Post: #4
RE: Problem with INPUT()command in RPN mode
(05-14-2015 01:27 PM)wawa Wrote:  Hello

I have a problem using the INPUT command in RPN mode : In a simple program like this :
Quote:EXPORT TEST()
BEGIN
INPUT({A,B});
END;

When I try to enter a negative number for A or B, Something strange happens : Single quotes are added in the edit line around my number and when I press OK, I have an Invalid Entry error. If I remove single quotes around my number, then it is OK. With positive numbers, no problem.

When I am in textbook or algebraic mode, I have no such problem.

I use the latest firmwrare (05/2015) but the problem was here also with the previous ones.
Even when I enter a positive number, I get the single quotes!

Tom L

Tom L
I think therefore I am-Descartes
I think therefore you are-Gorgias
You're not here to think-Army Sergeant
Find all posts by this user
Quote this message in a reply
05-15-2015, 07:20 AM (This post was last modified: 05-15-2015 07:21 AM by wawa.)
Post: #5
RE: Problem with INPUT()command in RPN mode
Yes but with positive numbers, they make no harm. Ideally, there would be no quotes automatically added. In this case, everything works well.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)