Post Reply 
Digit grouping does not work in CAS
05-14-2015, 01:24 PM
Post: #1
Digit grouping does not work in CAS
I have Digit Grouping set as 123,456.789, which works fine in Home, but omits the comma in CAS and displays as 123456.789

I just updated to the newest firmware version.
Find all posts by this user
Quote this message in a reply
05-14-2015, 02:20 PM
Post: #2
RE: Digit grouping does not work in CAS
More on the grouping...

Storing a function with grouped numbers fails when editing values.

1. Adding contents
   

2. View stored function
   

3. Edit stored function
   
Find all posts by this user
Quote this message in a reply
05-14-2015, 06:00 PM
Post: #3
RE: Digit grouping does not work in CAS
(05-14-2015 01:24 PM)Michael de Estrada Wrote:  I have Digit Grouping set as 123,456.789, which works fine in Home, but omits the comma in CAS and displays as 123456.789

I just updated to the newest firmware version.

It's always been like this since digit grouping stuff was introduced. The CAS doesn't allow digit grouping display at this point yet as it caused other issues. It is definitely something we want to be able to support though.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
05-14-2015, 06:02 PM
Post: #4
RE: Digit grouping does not work in CAS
(05-14-2015 02:20 PM)petaks01 Wrote:  Storing a function with grouped numbers fails when editing values.

Thanks. I've put this on the list of things to fix. It should not be using the "display" form of the equation when you go to edit. The display form puts in the separators which don't parse thus causing the issue.

To avoid this, you can edit the variable directly on the home screen, or manually remove those separators, or not use the separators.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
05-14-2015, 06:12 PM
Post: #5
RE: Digit grouping does not work in CAS
Even with the separators removed during editing it fails to save the data, only get yellow exclamation mark when trying to save from the memory editor ("Input" screen).

   
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)