Post Reply 
BUG in Conn Kit
12-18-2014, 11:08 AM
Post: #1
BUG in Conn Kit
Open Conn Kit
Bring up a Spreadsheet
Highlight a Range of Cells.
Copy
Open Excel Spreadsheet (or a ASCII text editor)
Paste
Works fine
(of course functions probably not recognized but I'm mainly thinking about number data)

Then Reverse

Open an existing Excel Spreadsheet (say just two columns of plain numbers)
Copy
Open Conn Kit
Bring up a Spreadsheet
Paste into Spreadsheet

Conn Kit crashes

very major problem

neither method works for a Matrix.
Find all posts by this user
Quote this message in a reply
12-18-2014, 02:46 PM
Post: #2
RE: BUG in Conn Kit
This is a known issue since the prior release. None of the connkit editors were touched at all for this revision.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
12-19-2014, 05:32 AM
Post: #3
RE: BUG in Conn Kit
Yuck. What a revolting development that is.
As I get to looking at the User Guide maybe I'll see another way to transfer data, hopefully
Find all posts by this user
Quote this message in a reply
12-29-2014, 09:09 AM
Post: #4
RE: BUG in Conn Kit
The obvious question is:

How does a MAJOR flaw like this even get into ANY release in the first place?
example: I bought a new car and the heater doesn't work.
Is there any testing done at all?
How long has it been known?
I've been playing with the machine for only a few weeks and have found many major problems.
Can I get paid as a Beta Tester?
I'm just flabbergasted.
Find all posts by this user
Quote this message in a reply
12-29-2014, 08:07 PM
Post: #5
RE: BUG in Conn Kit
(12-18-2014 02:46 PM)Tim Wessman Wrote:  This is a known issue since the prior release. None of the connkit editors were touched at all for this revision.

Tim,

I think I see the problem. When copying from an Excel spreadsheet, on the clipboard the contents of each cell is separated by a tab (0x09) and each row is separated by a CR/LF (0x0D/0x0A). The trailing CR/LF on the last row seems to cause the Connectivity Kit to crash.

If I copy the selection from the Excel spreadsheet into a text editor and manually remove the last CR/LF, I can then re-select the remaining text and copy and paste it into a Spreadsheet opened in the Connectivity Kit.

I doubt that this will be acceptable to the OP. However, for others, this might be a useful work-around.

Ceci n'est pas une signature.
Find all posts by this user
Quote this message in a reply
12-30-2014, 01:07 AM
Post: #6
RE: BUG in Conn Kit
(12-29-2014 08:07 PM)Mark Hardman Wrote:  I think I see the problem. When copying from an Excel spreadsheet, on the clipboard the contents of each cell is separated by a tab (0x09) and each row is separated by a CR/LF (0x0D/0x0A). The trailing CR/LF on the last row seems to cause the Connectivity Kit to crash.

Interesting. Thanks for that.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
12-30-2014, 05:18 AM
Post: #7
RE: BUG in Conn Kit
I'll try it out. Thank You.
Maybe I can write a VB program for this simple task to make it as easy as possible.
Find all posts by this user
Quote this message in a reply
12-30-2014, 06:15 AM
Post: #8
RE: BUG in Conn Kit
I just tried this workaround and was not successful.

Opened an Excel 2007 Spreadsheet.
Populated it with my typical data. Mostly numbers some Text.
Exported as a Tab Delimited Text file.
Opened it in Ultra Edit ASCII.
Lopped off the last two "characters" in the file.
Selected and Copied to Clipboard.
Pasted into the Spreadsheet App opened in Connectivity Kit.
It was there.
(BTW - using Ctrl V doesn't work. Have to use the Paste in Right Click Menu. Oi)
Closed the Spreadsheet and told it to Save Changes.
Reopened the Spreadsheet and of course nothing is there.

Am I missing something?
Should be an intuitively simple task.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)