Post Reply 
My System Apps Were Gone After Firmware Update
04-08-2021, 03:49 AM
Post: #1
My System Apps Were Gone After Firmware Update
First off, l'd like to thank you for taking some time out to read this.

I just bought a used HP Prime G1 Rev A from an individual today.
It looks really clean and doesn't show any sign of abuse. However, the owner apparently never updated the firmware. When I checked it iwas on CAS version 1.1.0-27, from 2013 I believe. So I immediately wanted to update it to whatever that was recent (2020 01 16). I already had the latest Connectivity Kit installed on my PC. I plugged the calculator in, it automatically booted to the recovery mode without me doing anything at all. I then got a prompt on the computer asking if I wanted to update. The whole update took less than 3min. After it rebooted, except for the regular explorer app, all the other explorer apps where gone (Quadratic, trig, and linear explorer) ; the data Streamer apps was grayed out as well. Any suggestion would be much appreciated.

Thank you in advance.
Find all posts by this user
Quote this message in a reply
04-08-2021, 11:50 AM
Post: #2
RE: My System Apps Were Gone After Firmware Update
Hello,

That is correct. The "explorer" apps were combined to a more interesting and interactive one that lets you pinch and zoom and manipulate a wider range of functions then those 3 combined.... The "Streamer" was for a streaming device you probably will never see, but we had to disable it on Rev A prime hardware.

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
04-09-2021, 04:30 AM
Post: #3
RE: My System Apps Were Gone After Firmware Update
(04-08-2021 11:50 AM)Tim Wessman Wrote:  Hello,

That is correct. The "explorer" apps were combined to a more interesting and interactive one that lets you pinch and zoom and manipulate a wider range of functions then those 3 combined.... The "Streamer" was for a streaming device you probably will never see, but we had to disable it on Rev A prime hardware.

Thank you for the quick reply. I tried to downgrade the firmware to a much older one because I wanna try something. But the Connectivity kit just won't let it happen. Though the 20200116 firmware gets defected every time.
I've read several threads here about downgrading, but it's still a wrap for me. I got the firmware from here:

https://www.hpmuseum.org/forum/thread-14...=Downgrade

I'm thinking maybe HP blocks firmware downgrade after upgrading to a certain version.

I've also attached a image of my screen.


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)