Post Reply 
Matrix editor bug in Free42?
11-19-2020, 04:58 PM (This post was last modified: 11-19-2020 05:02 PM by JSBach.)
Post: #1
Matrix editor bug in Free42?
Hi,

if I create a matrix in Free42 and edit it in the Matrix editor, I get the edited matrix in X (correct) and a 0 (zero) in Y, which I think is incorrect.
(Free42 2.5.21, Windows.)

Stack before matrix editor:
T: 1
Z: 2
Y: 3
X: [ 2x2 Matrix]

After matrix editor:
T: 2
Z: 3
Y: 0
X: [ 2x2 Matrix]

IMO this should be:
T: 1
Z: 2
Y: 3
X: [ 2x2 Matrix]

Or did I overlook something?

Regards
JSBach
Find all posts by this user
Quote this message in a reply
11-19-2020, 05:59 PM
Post: #2
RE: Matrix editor bug in Free42?
Same behaviour as in the 42S I’m afraid.
The first element you enter will push the 0 to Y, and there it stays till you EXIT the editor.
Cheers, Werner
Find all posts by this user
Quote this message in a reply
11-19-2020, 06:40 PM
Post: #3
RE: Matrix editor bug in Free42?
Yep. The stack lift behavior in the HP-42S matrix editor is a bit odd. Buggy, even. And Free42 emulates this behavior, in order to avoid introducing incompatibilities that might break programs that depend on the original behavior.

See the release notes, for releases 2.0.18, 2.0.19, and 2.0.20.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-20-2020, 08:38 AM
Post: #4
RE: Matrix editor bug in Free42?
Hello Werner & Thomas,

thank you for the information!

Regards
JSBach
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)