Post Reply 
HP9100A failure after years in storage
02-11-2020, 12:25 PM
Post: #1
HP9100A failure after years in storage
The 9100 was working when put into my loft but is now faulty. I have been receiving some very good suggestions from Trevor Marshall and Tony Duell but I am really struggling to locate the fault because I don't have schematics/layouts for the arithmetic unit.

I have the 9100A field service manual but this only covers the power supply, keyboard and display and these functions appear to operate correctly in my machine.

I do also have good schematics for the 9100B but these very different in many ways. If anyone could point me to where I might find the 9100A schematics I would be very grateful.

So far with lots of help from Tony and Trevor I have diode checked every transistor and diode on all the assemblies and carefully eye-balled all solder joints and cleaned all edge connectors. I have confirmed the -15 volt, -9 volt and -2.4 volt rails and generally cleaned the assemblies with compressed air.

The fault is that it powers up and displays the three registers and although all the keyboard keys are active, the numeric entry is not entered except for the Pi key. The arithmetic operators do work as do the register operators but pressing any of the trig keys causes the display to blank and no key or switch operation will return it except by power cycle.

Having cycled the power the display returns but it has two modes. It either operates as in the paragraph above or by pressing absolutely any key the display blanks again.

It is possible to get out of this mode by entering a program from the magnetic card reader.

Thanks for any suggestions,

Peter
Find all posts by this user
Quote this message in a reply
02-13-2020, 10:36 PM
Post: #2
RE: HP9100A failure after years in storage
Are there any capacitors that can be replaced? Old capacitors are often faulty and should be replaced by new ones. This is a common cause of problems in all vintage electronics equipment.
Find all posts by this user
Quote this message in a reply
02-14-2020, 01:20 PM
Post: #3
RE: HP9100A failure after years in storage
I have checked few of the electrolytics but found them to be good. There are a lot disc ceramics on the sense amps but I think they are generally very reliable for leakage. The rail voltages look clean and good.

Thanks,

Peter
Find all posts by this user
Quote this message in a reply
02-14-2020, 02:33 PM
Post: #4
RE: HP9100A failure after years in storage
Dear Scott,

A promising approach to locate the origin of the problem is to swap circuit boards with a running machine - one-after-the-other. I have a working 9100A and I’m willing to help you, but I‘m located in Germany Rhein-Main-Area. Looking at your profile you are located in Scotland. Whenever you‘ll have the opportinity to come to Germany, bring your machine and a bottle of good whisky with you and I will help you :-)

Regards
Roland
Find all posts by this user
Quote this message in a reply
02-15-2020, 08:13 AM
Post: #5
RE: HP9100A failure after years in storage
Thanks Roland, That's a very kind offer.

Regards,

Peter
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)