Post Reply 
Demo_PISERIES program shows blank screen
10-11-2018, 09:53 AM (This post was last modified: 10-11-2018 10:11 AM by toml_12953.)
Post: #1
Demo_PISERIES program shows blank screen
I'm trying to run the Demo_PISERIES program from the TEXTOUT Help screen.

All I get is a blank, white screen. Other graphics programs I wrote myself work fine so I'm pretty sure the hardware is good. It's a G2 with the latest Beta firmware.

Tom L
...other than that, Mrs. Lincoln, what did you think of the play?
Find all posts by this user
Quote this message in a reply
10-11-2018, 10:26 AM
Post: #2
RE: Demo_PISERIES program shows blank screen
Rad/deg setting problem? (Just a guess, did not look at the source)

TW

Although I work for the HP calculator group, the views and opinions I post here are my own.
Find all posts by this user
Quote this message in a reply
10-11-2018, 11:16 AM (This post was last modified: 10-11-2018 11:16 AM by Didier Lachieze.)
Post: #3
RE: Demo_PISERIES program shows blank screen
(10-11-2018 09:53 AM)toml_12953 Wrote:  All I get is a blank, white screen.

What are your values for Xmin, Xmax, Ymin and Ymax? These are defining the visible part of the cartesian plane. It should match with the area where the TEXTOUT instructions in the Demo_PISERIES program are printing.
Try with: Xmin=-10, Xmax=10, Ymin=-10, Ymax=10
Find all posts by this user
Quote this message in a reply
10-12-2018, 06:08 AM
Post: #4
RE: Demo_PISERIES program shows blank screen
Hello,

I just tried it and the program worked fine...
My best guess is that, since the program is using TEXTOUT and not TEXTOUT_P, you have a non-default value for the cartesian plan.
Select function app, go to plot setup and reset the values (shift clear), it should then work.

Cyrille

Although I work for the HP calculator group, the views and opinions I post here are my own. I do not speak for HP.
Find all posts by this user
Quote this message in a reply
10-12-2018, 02:10 PM
Post: #5
RE: Demo_PISERIES program shows blank screen
(10-12-2018 06:08 AM)cyrille de brĂ©bisson Wrote:  Hello,

I just tried it and the program worked fine...
My best guess is that, since the program is using TEXTOUT and not TEXTOUT_P, you have a non-default value for the cartesian plan.
Select function app, go to plot setup and reset the values (shift clear), it should then work.

Cyrille

Quite correct! I had just plotted sin/cos/tan curves and didn't change the coordinates back. When I changed them to x: -10 to 10, y:-10 to 10 the demo worked.

Thanks to all who answered!

Tom L
...other than that, Mrs. Lincoln, what did you think of the play?
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)