Post Reply 
Emulator of HP 50g with #2.16 ROM
09-29-2016, 11:16 AM
Post: #12
RE: Emulator of HP 50g with #2.16 ROM
(07-24-2015 03:46 AM)Skyblues Wrote:  I downloaded and installed the HP50gVirtualCalculatorSetup_3_1_30 file.
I really like the display and size on this emulator. It's larger and darker than the previous emulator I was using.

I'm having a problem loading libraries, though. I tried to copy a *.hp library I have and when I do, I am getting an error message "Cannot load an empty file".

Per the emulator help that came with it, I tried to follow the instructions thinking that maybe I could load libraries if I use Virtual USB Port.

The Virtual USB Port is defaulted to Disabled and it won't let me change it.

This is too bad as it seems like a great emulator. If anyone figures this out, please let me know.


Hi Jim, and all you folks, I'm new to this forum.
Some day ago I too began tampering with this emulator on a win7/64 PC, did the same you did and got into the same deadlock.
So I tried to install in an older box running XP SP3, and there it worked some way before crashing into BSOD.
The relevant fact was that in this case I had the emulators' virtual port exposed as per the Manual, I could see it on connection kit and have both connected for a while before they crashed into BSOD.
After restarting the PC and emulator I went on Device Manager, did a device rescan
and could see a COM12 new port, confirming the virtual port creation.
Then I came back to the win7/64 and, after a reinstall, I looked there for a similar device. None. Went on the installed programs and saw "HP Virtual Calculator Port 3.1.11", and guessed the problem was there.
So I went to the Program Files(86)\Hewelett-Packard\HP50g Virtual Calculator\setup and tried to manually launch "HPVirtualCalculatorPortSetup.exe". That time I came up with a system warning message saying it was impossible to install a win-32 driver onto win-64 system. This led me thinking a an x-64 driver was needed. I wasn't then able to reproduce the situation for confirm.
BTW, I then attached my true HP-50g to the PC, via the USB cable, and it was detected and connected with Connx (HP 48g-49g-50g series Calculator Connectivity Kit) on "USB Calculator Port". I closed Connx, restarted Xmodem on the true 50g and launched the virtual one. This time, on Calculator/Preferences, a "virtual USB Port" named HP9xG+ DEVICE was available and Device Manager sees it. Now both the real and the virtual HP50g are in Xmodem server waiting for command... I'm very confused. That's all, at present. Can anybody suggest an x-64 driver to be used instead of that HPVirtualCalculatorPortSetup.exe?
Best regards
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Emulator of HP 50g with #2.16 ROM - robocat - 09-29-2016 11:16 AM

User(s) browsing this thread: 1 Guest(s)