Post Reply 
hp35s vector input bug semi-workaround?
03-17-2014, 04:38 PM
Post: #1
hp35s vector input bug semi-workaround?
Am I years too late? Has a workaround already been posted for this?

I got my 35s (and for all its faults, I have still come to like it, but I digress) and while going through the Vectors section of the manual, for some reason, entering any vector with more than one dimension gave me a "Syntax Error".

I couldn't find anything on an internet search, only vague clues that it exists. Some users mentioned that it caused them some grief. Can anyone tell me if the following helps / works for you?

If you enter a 2-D vector (while the HP35s is willing to work), press enter and it will push it on the stack.

If you now enter an expression in the equation editor (could be anything as simple as a single RCL X), then going back to the stack, entering a 2-D vector causes the syntax error when enter is pressed. (1-D vectors worked for me, but 2-D vectors cause a syntax error that sends the cursor under the first digit after the comma).

Now, if you delete that equation you just entered, it starts to behave good again.

What if you wanted to keep that equation/expression? If you enter an expression that you want to keep, but causes vector syntax errors, then put more (useless space-filler) expressions into the equation editor. Try a bigger one, like for example sin(x)*inv(sqrt(x)) and it MIGHT start to work. If it didn't, then try another one. This has worked for me.

So this half-solution is vague, but just try sticking random equations/expressions into memory. That way you may not have to erase all your programs trying to get it to work again.

All good fun.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
hp35s vector input bug semi-workaround? - pkh - 03-17-2014 04:38 PM

User(s) browsing this thread: 1 Guest(s)