HP Forums
Help programming WP 34s - Printable Version

+- HP Forums (https://www.hpmuseum.org/forum)
+-- Forum: Not HP Calculators (/forum-7.html)
+--- Forum: Not quite HP Calculators - but related (/forum-8.html)
+--- Thread: Help programming WP 34s (/thread-14210.html)

Help programming WP 34s - merlin04 - 12-22-2019 04:32 AM

I'm trying to program an HP 30b to be a WP 34s, but I'm encountering problems. I've successfully erased the calculator (at least I think I have, the device doesn't display anything when I turn it on anymore) but I'm stuck on the programming part. I've tried both MySamBa and the flash tool in the SourceForge page on both Windows 7 and Windows 10 with a variety of compatibility settings, but a few seconds after I click the flash button, both say something along the lines of "error connecting." I'm using a CP2104 USB to Serial adapter, and I'm powering the calculator off of the 3.3v pin. I've tried connecting the wires by holding them on the pads (with and without the case closed) as well as by using a custom pogo pin board I made.

Any idea how I can fix this?

RE: Help programming WP 34s - John Galt - 12-22-2019 07:16 PM

Hi Merlin, welcome to the project!

I hope I can help. If you have not done so already, you may find it helpful to revisit my notes here: [WP-34S] Cable and flashing options for Mac users. With no programming cable, no Windows PC and no desire to get one, the challenges I needed to overcome were almost certainly greater than yours, but I ultimately prevailed. If I could do it, anyone can!

Being greeted with a blank display is certainly frustrating since there is no way to determine whether the calculator is "on" or not. If it doubt press the ON key again, which will ensure it's in the proper state and ready to be programmed.

What test equipment do you have, if any? You don't really need anything, but the ability to measure current would be a big advantage. At the other extreme a digital scope would be a luxury.

(12-22-2019 04:32 AM)merlin04 Wrote:  ... a few seconds after I click the flash button, both say something along the lines of "error connecting."

Let's start at the beginning. What is its exact wording? It's important.

RE: Help programming WP 34s - merlin04 - 12-22-2019 07:45 PM

Thanks for the help. I looked over the thread you linked, and I couldn't find anything that I thought I could try except for different programming cables (which I only want to try after I exhaust all other options, as this was intended to be a Christmas gift so I wouldn't have time to order a new cable). I've also tried an Arduino Nano (following the guide in the sourceforge repo), and it didn't work either. I usually use Linux, but I wanted to use MySamBa so I tried using Windows (I didn't know about the other tools until I had already downloaded everything).

I always press the on button before I flash, so I think it would be on when I flash it.

I have a multimeter, an adjustable power supply, and one of those $20 oscilloscopes.

The exact wording from MySamBa is "Error: Unable to Connect," and the other flashing tool says it didn't get a response from the calculator.

RE: Help programming WP 34s - John Galt - 12-23-2019 12:23 AM

Here are a few preliminary thoughts that might go toward minimizing any unknown factors.
  1. If you prefer Linux that's ideal as far as I'm concerned. What I don't know about Windows would fill several books, with several chapters devoted to "com ports" alone.
  2. Therefore all my programming efforts used Ubuntu Linux and Wine. Linux-specific instructions: How to Install Wine on Ubuntu 18.04 Bionic Beaver. I followed them explicitly, it worked perfectly, so I did not perceive a need to document anything specific. If you have any Linux / Wine related questions they're probably already addressed in that other thread. Your knowledge of Linux certainly eclipses mine, but please ask if anything is not abundantly clear.
  3. I attempted to flash the calc using programs other than MySamBa, but none of them worked. At least one of them should not be hosted on the Sourceforge site because its output bore no resemblance to anything that could possibly work. As I understand the HP30b, timing is critical. MySamBa has been reliable for me so I recommend sticking with it.
  4. The calc's power supply is also critical. Maintaining adequate and correct voltage throughout the flash cycle is required. Your desire to power the calc through J31 instead of relying upon possibly weak batteries is good, and I agree with it, but you might want to consider using your bench power supply. One less thing to worry about. (Edit: see this post. The programming pad itself is inadequate to power the calc, at least with the pogo pins Iā€™m using. So use your power supply.) I bricked one calc due to what I suspect was a Vcc power interruption during a flash cycle. Admittedly I had to work at it though, demonstrating it's difficult but not impossible to brick one. I've programmed and reprogrammed hundreds of times and that was my only casualty. Conclusion: Make it effectively impossible to lose power while flashing it.
  5. Suggestion: I lost an embarrassing amount of time trying to figure out why I couldn't make my system work. In the end the culprit was incorrect documentation for my $1.79 USB to serial device, whose labels for Tx and Rx were swapped. That was it. Color codes mean zip so don't rely upon them. You can't possibly harm anything by switching Tx / Rx, so try it. I recommend using a 1k resistor in each to obviate concerns about possible level differences.
  6. Observation, using my bricked WP34s: MySamBa sends three short but distinct bursts of data to the calc at about one second intervals before it gives up. That takes about three seconds, during which the Windows "Send File" button remains "down". This same timeout will occur if you neglect to turn your calculator on before attempting to flash it. On the other hand if MySamBa cannot even get so far as to access its designated "com port" then the "Error Unable to connect" dialog appears immediately. This observation may help you to determine where the problem lies.
Worst case scenario: Won't be in time for Christmas, but (assuming you're in the US) you could always send it to me and I'll flash it.

Or, confirm it's really dead :-(

RE: Help programming WP 34s - burkhard - 12-24-2019 06:06 AM

I dunno, I've flashed WP34s many times using no power but the calculator batteries and while it sometimes took a couple of tries holding wires to the pads, it didn't break anything. I now have the official flash cable, which is less fiddly, but both work. I've flashed these successfully under both Win 7 and Win 10

It seems like you get the communication error on MySamba right away. Are you sure you have MySamba configured for the proper COM port under Windows Device Manager? If that is wrong, an error like what you are seeing will result.

Go Control Panel ā†’ System ā†’ Device Manager ā†’ Ports and verify whether it's COM5, COM7, or whatever that the USB cable gizmo is using. MySamba comes up with some default, but it has no idea what the proper setting is until you tell it. Make sure MySamba gets set to agree with reality.

Good luck!

RE: Help programming WP 34s - merlin04 - 12-24-2019 06:03 PM

It turns out that I had swapped TX and RX. I flipped them around and it programmed first try.

RE: Help programming WP 34s - burkhard - 12-24-2019 08:19 PM

(12-24-2019 06:03 PM)merlin04 Wrote:  It turns out that I had swapped TX and RX. I flipped them around and it programmed first try.

Great news! Now that you are "tooled up", you need to make a bunch!