HP Forums
HP 41CV problems - Printable Version

+- HP Forums (https://www.hpmuseum.org/forum)
+-- Forum: HP Calculators (and very old HP Computers) (/forum-3.html)
+--- Forum: General Forum (/forum-4.html)
+--- Thread: HP 41CV problems (/thread-13182.html)

HP 41CV problems - nhkader - 06-25-2019 11:13 PM

Hi All,

I’m new to this forum.

I’ve had an HP41CV since 1982. For the past 20 years I haven’t used it and it was stored without the battery. The battery springs broke, so I ordered some new ones from the Calculator Store in Spain. The calculator started without any problems but I have a few issues:
1. I cannot execute Size 319 as it returns with TRY AGAIN.
2. When I set Size to 000 I only get 46 Registers instead of 319
2. I’m unable to store to 00, 03, 04, 07, 08, 11, 12, 15, and 16. The all return with NONEXISTENT.

Could the memory have been damaged in the calculator being unused for 20 years? It seems to manage most other functions.

One other matter, when I put it in PRGRM mode it only shows REG 46.

I’ve tried a full reset, shorting the battery terminals all without success.

Help appreciated.

RE: HP 41CV problems - Karl-Ludwig Butte - 06-26-2019 09:59 AM


Raymond Del Tondo described in this old forum thread the procedure:

"Press [XEQ] [ALPHA] S I Z E [ALPHA] 0 0 0 , then press [PRGM] again.
On an empty CV or CX unit, the display will show '00 REG 319' ."

as a way to test memory:

"This way you'll see that the RAM chips are there,
and are likely to work."

In addition you may try a memory test routine which is described here. The actual program is on this page. The German description may be translated with deepl.com.

But perhaps there is not that much hope that all memory modules in your 41CV survived.

Best regards


RE: HP 41CV problems - nhkader - 06-26-2019 12:57 PM

Hi Karl,

I've tried the SIZE command. It cannot recognise 319. It's like my CV has lost its expanded memory and also some of it regular registers. Look like the NVRAM has lost their mojo.

I tried to key in the program but clearly something has gone wrong with my processor board. I tried to key in RCL IND Y but once I complete this program step it reflects as RCL IND T. Strangely if I do STO IND Y that is encoded correctly. Something is a bit wonky with my processor and memory board is all I can say. I will try to do the MEMTEST on my simulation of the i41CX on my iPhone to see how it works.

I fear my calculator could give me unreliable results hence I have elected to change the processor board and already purchased another one.

If all this fails, I will then upgrade to a CL.

Thanks again

RE: HP 41CV problems - nhkader - 06-26-2019 01:26 PM

Managed to run the MEMT. It beeps and turns the calculator off.

Clearly a memory problem.

RE: HP 41CV problems - Dave Britten - 06-26-2019 04:58 PM

If you're planning to open it up anyway to install a 41CL, you might as well try cleaning all the connectors first. Use a combination of things like 98-99% isopropyl alcohol, electrical contact cleaner, DeoxIT, etc. I had to do some pretty thorough contact cleaning on my 41CV a couple months ago. The numerous pressure connections inside the calculator are extremely sensitive to contamination.

RE: HP 41CV problems - nhkader - 06-26-2019 07:09 PM


Thanks for that useful tip. I’ve actually purchased another 41CV board to get it back to what I had in 1982 when I did Chem Eng at university. It’s pure nostalgia. If these type of problems persist, I will eventually take the plunge to the CL board.

But I will clean the contacts and be extremely mindful of the plastic posts as my calculator has not ever been opened.

Thanks for the useful responses.

RE: HP 41CV problems - g8241CV - 06-27-2019 12:19 AM

+1 Deoxit. Highly recommended if you're going to the trouble of opening the unit. Provides electrical properties improvement for keys plus the mechanical improvement of silky smooth key operation.