HP Forums
Bug in "apply" - Printable Version

+- HP Forums (https://www.hpmuseum.org/forum)
+-- Forum: HP Calculators (and very old HP Computers) (/forum-3.html)
+--- Forum: HP Prime (/forum-5.html)
+--- Thread: Bug in "apply" (/thread-10459.html)

Bug in "apply" - John P - 04-06-2018 11:20 PM

When I have: matrix m1 and do: apply(x->sin(x),row(m1,1)), OK, but when I do apply(x->sin(x),row(m1,1)*pi/180) or apply(x->sin(x*pi/180),row(m1,1)) it crashes the VC, it does not matter if I do * or .*. BTW I have the latest version of VC.

RE: Bug in "apply" - Arno K - 04-07-2018 08:38 AM

I tried both versions using matrix M1 where I have data in, they worked. Then I made a matrix m1:=[[1,4],[5,7]] and they worked.

RE: Bug in "apply" - DrD - 04-07-2018 09:33 AM

I did the same thing as Arno. No problem here, either. In earlier firmware, after a lot of activity I found it necessary to use the VC menu bar:

Calculator | Reset.

This seemed to clear weird problems including crashes where, otherwise, the VC would not crash. On the latest firmware, I haven't had to do that, so this may not help.


RE: Bug in "apply" - John P - 04-07-2018 11:51 PM

Thank you all.
I "restarted" the VC and now it works. What it was doing before was that VC hanged up and when I pressed "ON" the VC crashed.