HP Forums

Full Version: been having trouble getting results in CAS system
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
...when using variables instead of numerics. I've encountered this kind of problem repeatedly....but this is a typical example.

The function I'm analyzing is y=(z^n-x^n)^(1/n), n and z are integers. I'm only interested in x in the interval [0,z].

The equation for the length of the function curve in the interval [a,b] is:

So, I was hoping to get an equation in terms of z,n, a and b.

So, I entered the following:
l:=int((1+(dy/dx)^2)^1/2,x,a,b) (it's lower case L).

It hangs there for a minute or two as it calculates this, and then prints out a bunch of stuff, and when I hit enter again, it gives an integral as the result, rather than solving the integral.

Give it a try. Curious as to why it can't solve it.

Then I tried n:=3 to solve for a specific case, and it printed a bunch of stuff again when I typed lower case L and I hit enter again, which gave me another giant complicated integral of a square root of a big polynomial plus an inverse polynomial. I tried setting a to 0, but none of these gives me an answer....

....I know the probable answer is "it's too complex", but that seems like a copout....
any suggestions?

You should realize that it is almost never possible to find a closed form for arclengths (antiderivative of sqrt(1+diff(f(x),x)^2)) in terms of usual functions. There are only a few exceptions, like the parabola or the cycloid, but even for an ellipse it would involve special functions (elliptic integrals).
Ah, I didn't realize, we already have an arcLen() function.
So, I can use arcLen(y(x),x,a,b)
Of course, you are right....it's not easy to calculate using this format....is the same math internally.

So, if I set z:=1, n:=3, a:=0, b:=1

y = (1-x^3)^(1/3)

dy/dx = -x^2/((1-x^3)^(1/3))^2

(1+(dy/dx)^2)^(1/2) = ((-x^2/((1-x^3)^(1/3))^2)^2+1)^(1/2)

So, now, we can calculate int((1+(dy/dx)^2)^(1/2),x,0,1) like this, and it'll give a value of 1.

However int(((-x^2/((1-x^3)^(1/3))^2)^2+1)^(1/2),x,0,1) hangs for a minute and gives an answer of an integral...i.e. doesn't get solved.

Why does it work with dy/dx but not with the expanded form????

int((1+(dy/dx)^2)^(1/2),x,0,1) giving 1 as an answer is also wrong.

y=(1-x^n)^(1/n) is y^n=1^n-x^n or x^n+y^n=1^n

For n=2, this is the equation of a circle with radius 1.
I'm only interested in quadrant 1 (Q1), integrating from 0 to 1.

This means for n=2, L is quarter the circumference of a circle of radius 1.
L=2*pi*r/4 = 2*pi/4 = pi/2 = 1.57

For n=infinity, it becomes a square pulse, so L = 1+1 = 2

So, for n=3, L must be somewhere between 1.57 and 2.....around 1.7 or so, not 1 as in previous post CAS system.

So, if I can figure this out in my head, there must be a mathematical way to determine L for n=3.

Any ideas?

dy/dx is not a valid input.
For any value of n, you can get an approx value, but there is no closed form (at least for every boundary values without introducing special functions). You should realize that for a random expression, there is 0 chance to get a closed expression for the antiderivative. There are only a few classes of expression where it works. Math exercices are biaised, because they are almost all solvable, but it's not real life.
Well, the engineer in me is thinking, the way to do this is to approximate the curve
y=(1-x^n)^(1/n) using some regression function that allows me to get the length. It's a bit easier because I'm only interested in the first quadrant.
I'll have to play around with this.... I'll post when I get something worked out.
If you want an approx value, there is nothing special to do, just enter approx boundaries and you will get the approx length (assuming n is known of course).
Reference URL's