HP Forums

Full Version: Lost STO (▶) symbol in the connectivity kit program tab
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
A while back I had to do a clean install of win xp sp3 back on my laptop. After that install, I was unable to get the connectivity kit to install, but the Prime emulator would install. I finally googled the error message it was popping up, and it pointed me to some C runtime libraries I needed to install. Did that, finally got connectivity to install and run, but I'm missing the STO symbol. I've uninstalled and reinstalled the connectivity kit several times after installing the C libraries to no avail. This STO (▶) symbol was copied directly from the connectivity kit program tab program code, but all the connectivity kit code shows is what appears to be a square block. I checked the fonts folder, and I do have the Droid fonts installed. The Prime emulator shows the symbol correctly. Any suggestions or help would be appreciated.
If that character was visible before, then I think it is more likely you are in need of a font that you used to have but is now no longer available due to the reinstall.
(03-27-2014 11:35 PM)Bob Frazee Wrote: [ -> ]I finally googled the error message it was popping up, and it pointed me to some C runtime libraries I needed to install.

If you still have it, could you possibly send me what that was? I thought all needed things would be packaged along with it, but it is possible something may have been missed.

The font is loaded from a sub directory in your install dir - not your fonts directory.

However, it is also possible the unicode stuff is what is messing things up and not the font missing. Technically, HP doesn't support XP anymore (and neither does microsoft shortly) and so most of the testing efforts are spent on win vista,7,8. That doesn't mean we don't compile it to only require XP or greater, but I honestly have no idea how XP does with unicode stuff. I've seen plenty of times where unless you had a specific extension installed, or a language pack, everything just goes bonkers.

[EDIT] Someone pointed out what may be the error. The droid sans mono font is used in the program editor. However, that character doesn't exist in it. I believe if you remove the font from the install dir, or rename it at least, it will fall back to use a different one which will most likely have it.
I do have the fonts in the fonts sub directory of the install directory. The Droid...fallback.ttf file has the symbol in it. I renamed the other 2 and tried it. It still will not display the symbol, and the rest of the text is not the same font. If I copy the square block to windows notepad and select the Droid..fallback font, it displays correctly in notepad. Go figure. I think the error message that the connectivity kit was throwing was something of the form "program didn't install correctly, try uninstalling and reinstalling the program". I don't have the original connectivity kit file I originally installed from, but when I restarted the connectivity kit, it did say there was an update available, so I downloaded it. It was either absorbed into the connectivity kit file or sent to the bit bucket. I never did find it. At this point I'm not going to worry about it. I've found in the past, that when things like this happen, to correct it requires either messing with the register, or reloading the whole operating system. It's not worth it. Thanks for taking the time to reply.
Have you tried enabling Unicode in the Regional Options and Language Options as described at http://www.unicode.org/help/display_problems.html?

Just a thought.

Mark Hardman
Reference URL's