HP Forums

Full Version: Android app of WP-34s/31s?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi -
Here is something which might be an anomaly, or perhaps I'm doing something wrong. If I use the 34S Android version (on my Samsung Note 8) and "minimize" it to do other things, when I return to the app, it immediately resets to default settings and clears everything as soon as it is touched again. Is there a setting to change this? I haven't been able to locate any way to get to any settings.

Thanks in advance for any help offered,
Thank you all for the feedback!

There have being 117 installations so far which is quite encouraging.

johanw, the app only builds in Linux, and the Makefile provided already downloads gradle for that platform. There is some patching done on the original WP-34s code that requires the usual POSIX tools.

Jake: Probably in your phone the app is being restarted after going out of focus. This is why it is agreed the most important thing to do next is make the memory persistent between executions.

I have being terribly busy lately but probably in two weeks I will have time to fiddle a bit with this and do a new release.

Thanks very much!
Version 0.0.6 is in Google Play featuring persistem ram/flash storage.

Note that doing 'Clear Storage' on the application settings have the same efect as doing h [P.FCN] RESET on the calculator
Much appreciated!
Thanks, the persistent memory is really useful.

I've found an issue I think: when trying to integrate the following function from 1 to 9, the app stops abruptly while it works correctly on the WP34S.
(05-09-2021 09:08 AM)odkq Wrote: [ -> ]Version 0.0.6 is in Google Play featuring persistem ram/flash storage.
Would it be possible to publish a single universal apk on https://odkq.com/awp34s (that still offers 0.0.5)? The version in Google Play is a split apk so I can't download it once and then install onn all my devices without the Play Store (disabled for privacy reasons).
If you still develop this app, I can give bug report for you.

- Trying to calculate Zeta function results crash.
- In double mode, 5 sqrt f x<>y results crash.
- Integrate x^x from 0 to 1 results crash.
Hello Pablo,

adding to your to-do-list (that led me here) as a wish:
- display orientation (setting or fix to portrait for now?)
- clipboard support (copy paste number to/from X, maybe also strings, or even programs?)
- setting display permanently on vs. allow power-saving (is it actually permanently on?)

Quote:- Make calculator memory persistent between executions (DONE)
- Haptic/sound feedback on the keys
- Visual keypresses feedback
- Settings for the two above (sound volume, vibration strength)
- A way to store/load WP-34s (compiled) programs from the phone memory
- Realtime clock emulator
- Port the WP-34s assembler itself so programs can be loaded/stored in WP-34s mnemonics format (Examples at sourceforge.net/p/wp34s/code/HEAD/tree/library/ see README_ASM)
- Debugging display, showing the stack and/or registers
- Skins support

After I was very happy to have found your aWP32s 0.0.6 on 'play' and to have it installed, looking beautifully realistic and working smoothly at first glance on a Galaxy S8 with Android 9.0 (de-de), a few questions arose, though:
- When I accidently turned the device to landscape and back to portrait, I found the stack contents changed back to an earlier state (maybe it's a caching quirk provided by the Samsung UI?),
- I found no settings dialogue when I tried to find a setting to fix the display orientation to portrait - so I'd suppose the app should rather remain in portrait view, unless there will be a skin that supports landscape - and maintain it's registers unchanged... (I had also hoped I could have it full-screen with hidden status bar and soft-keys.)
- The introduction on 'play' did not tell that the link "source code" would get me nearer to the explanation why "STOPW" in X.FCN is replaced by "???" (realtime clock is 'to-do' yet), which also breaks the navigation-by-letter for anything after S - despite DATE and TIME giving correct results :-)
- When I had received my WP34s I found CAT* Lib quite populated, according the manual are details in the XROM trunk, and the programs are included in the firmware. I was a little puzzled to find Lib empty in awp34s. But I understand that the XROM is not part of the ported source (yet).
- So I found that there's also no I/O (by now) for numbers/strings or programs or status backups (or maybe virtually print to a text file) - it's on the to-do-list, but it should be mentioned in the introduction on 'play' also.

Beyond the described here I did not experience any crash or hang-up as reported by Didier and BINUBALL - I tried the given examples on both the S8 and an XCovery4s with Android 11 (SETEUR and Display ALL 3). Unfortunately I'm neither deep in Math nor coding (especially Android), so I can only report from my point as a user what I'd desire. (Once I found in a collection on Murphy's law: "Write an idiot-proof program, and only an idiot will use it..." ;-) We're learning by making mistakes, and a few learn also from the mistakes made by others ...)

All in all I'm glad to have this almost-WP34s now in my pocket and I'd be even more happy to see it live on and grow a little yet.

With the best wishes

*) Thanks to Pauli for the library link - after checking again Owner's manual page 72 and 73 about Flash and XROM I seem to better understand that XROM code is an internal part of the WP32s, and that what I found in my calculator's flash Library was an optional selection. D.

Finally I entered a first small program into aWP34s, and I stuck on the strange effect that I have to press [R/S] twice before the execution continues. I tried h [P/R] either immediately as well as after the first press of [R/S] in the loop - and I got the same line (immediately after the STOP) in the display. I tend to think it may be related to the realtime clock function - when I run X.FCN WHO on my WP34s, it automatically advances to the next line after briefly pausing. Not so on the aWP34s - here I have to press the DOWN arrow to advance. (And in my WP34s there's no Crystal installed, it does not show the X.FCN STOPW menu entry at all.) Btw. PSE 10 in place of STOP halts forever until I press any other key, like [h] or [DOWN], but not R/S (after R/S it shows "Stopped"). Although it may be related to my hardware - both smartphones are Samsung. Did anyone find anything similiar about [R/S] and PSE?

Simple loop:
001 LBL 'Stp'
002 1
003 ENTER^
004 +
005 STOP
006 RCL L
007 BACK 003
008 END

When I start with
instead of simply counting up I get:
2 R/S 2 R/S 3 R/S 3 R/S 4 ...
The CAT command lists installed keystroke programs. The XROM programs are not visible in this list -- they are internal and implement built in commands.

The CAT programs come from the library directory.

Pages: 1 2
Reference URL's