HP Forums

Full Version: HP-11C Self-Test Help
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am new to this forum and hope someone can help. I have an HP-11C calculator that I came across in my late father's belongings and am trying to see if it still works. I found instructions for running self-tests and the one using the "X" key worked fine. But when i try to do the keyboard test, I don't get an error code, but I do come up with a different number value on the screen at the end of each time I try the test. I have pushed each key in sequence left to right, top row to bottom row. I wasn't sure if i was supposed to include the "on" button in the sequence, but when I included it, the calculator just turned off. And if I push every other button in the testing sequence except the "on" button, I just get different values at the end each time. I don't know what I'm doing wrong or whether the calculator is just malfunctioning. Any insight would be appreciated.
Your calculator is probably working fine.

If it passed the ON and X test (multiplication key), then it is likely working.

The ON and + test is just the same test but runs indefinitely.

The ON and DIVISION SYMBOL test, which you are using to test the keyboard, must be performed by pressing the keys in order from LEFT to RIGHT and then TOP to BOTTOM. The sequence is crucial.

If the keyboard test is working properly, "different segments in the display area are lit" (quote from the Owner's Handbook, page 236). The ENTER key is pressed twice in this sequence.

If you press a key out of sequence, "Error 9" is displayed.

Otherwise, when everything is fine, "11" is displayed when you have pressed the last key.

ALTERNATIVELY you can just press keys normally when doing calculations to see if they work.

My guess is your 11c is fine.

I have two of them! They are great!
Thanks! I don't know what I did differently, but when I ran the keyboard test again, the "11" showed up in the window at the end like it is supposed to.
Reference URL's