HP Forums

Full Version: [SOLVED] CAS `solve` crash on simple expression with two variables
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
UPDATE: I got this working by re-flashing the firmware, using the procedure described here http://www.hpmuseum.org/forum/thread-404...l#pid65729 . So it looks like this was a false alarm.

Steps to reproduce:
1. Enter CAS mode
2. Enter `solve(x*y=0)`
3. Press Enter to evaluate
4. If the calculator doesn't reboot immediately, copy and evaluate the command a few more times (the first time seems to be enough to corrupt memory, but it doesn't always reboot immediately)

Observed behavior: Calculator reboots

Software Version: 2016 08 29 (10637)
I did a reset to factory settings.

I also tried reproducing this on the Android emulator, but wasn't able to do so.

I'm not sure if this is a regression or not. Is anyone still running an older firmware and willing to test this out?

Video of the crash: https://www.youtube.com/watch?v=O6dDDgE1QcE
In addition to the Android version, I also can't reproduce this with neither Giac 1.1.4 nor 1.2.2 on Linux. Though it's possible that there's still memory corruption, and it just doesn't cause a crash.
I checked giac with valgrind, no memory corruption detected.
Thanks for checking!

I think it might have been a false alarm. Sorry about that.

I just downgraded my calculator to 2016 06 17 and the crash didn't occur anymore. Then I upgraded back to the latest 2016 08 29, and it's still working fine.

My only explanation is that the firmware on my Prime somehow got corrupted when I updated it earlier today. It did hang at the end of the update and I had to reset it, though the connectivity kit said that the update had been complete at that point.
If I recall correctly, it was suggested to create a backup, then "Format Disk C," (Using the prime's C-F-O [ON], Option 4, utility), before launching the upgrade. This might have prevented that problem.

Reference URL's