HP Forums

Full Version: Problem with fractional exponents and negative numbers
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, I tried to elevate a negative number to a fractional number and I get an error in home and a complex number on CAS. Do you know how to fix it? Is it a configuration problem? Thank you.
Consider using NTHROOT.

Some discussion of the issue can be found here: http://www.hpmuseum.org/forum/thread-357...ht=nthroot
Tried to use it but I cant, It just returns a common root.
Can you be a bit more clear on what the issue is, then? You have listed what you typed into the calculator, but it is not clear what you were expecting as far as results go.
Hi German90,
Home settings; switch on "allow complex output from real input"
First we have to know how g^b is defined when b is not an integer.

So what would 0.47^3.1 be?

It is defined by means of the well-known functions e^x and ln(x), as follows:


This seems reasonable because e^[b*ln(g)]=e^[ln(g^b)]=g^b.

But when we use this definition in the case of g being negative we have to calculate the logarithm of a negative number, which does not exist within the realm of real numbers.

Within the realm of complex numbers such a logarithm exists though.

That is the reason why the result is a complex number, written as r+s*i, where r and s are real numbers, and i is the imaginary unit.
Reference URL's