HP Forums

Full Version: HP-41 - port not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a HP-41 here that does operate normally but I-O port 4 isn't. I have double-checked with some modules. Cat 2 does not show anything. Also card reader isn't operational in this calculator.
When I check the I-O block connectors as mentioned in the service manual everything seams to be ok.
What is the problem? Any ideas or experience?
I would start with checking connections to this port, especially on the flexible tapes and checking the screws holding the body of the 41c together.
Then you could check with an oscilloscope if the port gives any signs of life. As the other three ports are OK you could compare their electrical activity with dead port.
Technically it can be not so simple because you would have to insert a module to a port what will block the access to the connectors inside the port
Hi Andi,

Some pics of the disfunctional port would be of some help to check for contact tracks misalignment.

However, Ports 3 and 4 share the same internal wiring in the Flex PCB, therefore it is very unlikely that loose post screws may cause the problem as you've described it.

Apart from ROM modules, does the problem happen also with non-addressable or fixed addressed modules? (e.g. X-MEM, TIME, PRINTER...)

Is the calc an HP-41C? If so, please check if it also happen with Memory Modules (or the QUAD)

Check if plugging the module and taking it out by just one millimeter makes any difference.

Also, narrowing the gap between the module's contact may fix the problem. Even if this module works as expected when plugged into a different port. It may worth a try.

Best regards from Canary Islands
Thank you for your suggestions.
It's a CV so no 82106A or 82170A memory possible.

Checked with X-Func in port 3 and X-Mem in port 4. EMDIR does report 124 with X-Mem in port 4, 362 in port 2.

Next I did a reset, Memory lost. After each try decribed below I did a reset to Memory lost so I have the basic configuration before next test.

Then plugged in X-Func in port 4 (calculator off). Then ON.
Sometimes the calc immediately freezes, does not respond to any key. With sometimes weird display 0.0000 00 00
Sometimes after a single key press it shows Memory lost and then is frozen.
If I then remove the X-Func module it works perfect. But switching to program mode it sometimes shows 00 REG 273 or 03 or 05 or even PRIVATE.

So I think the calculator recognizes the module plugged in (and is confused) but has some irregularities concerning the timing or phi line?
BTW: I have no oszi, only multimeter.

What I measured some time ago was the I/O block.
I have connections (0 ohms, as shown in the service manual)
from port 1 Vcc to port 3 Vcc and B4, B3 to B3.
Port 2 Vcc to port 4 Vcc, port 2 Vcc to B3, port 4 Vcc to B3 and B4.


Thanks for the follow-up. It certainly looks quite like a data or clock line issue.

In case you haven't done yet, using a Q tip with isopropyl alcohol to clean the port's contacts, won't cause any harm either.

Please post your findings.

Dear Diego,

Did what you suggested again. Sorry, no success. Cleaned & tested a week ago but had no time to report.
Had the I/O block already cleaned when I repaired the calc itself. Also the zebra strip that was probably the problem it didn't power on at all.

Any other ideas?
Problem solved:
Was corrosion on one of the leads from port 4.
(09-05-2016 08:44 AM)AndiGer Wrote: [ -> ]Problem solved:
Was corrosion on one of the leads from port 4.
Hi, Andi, I have the same problem with a calculator bought recently on TAS, but after a clean with vinegrad it seems at the beginning to be perfectly working.
Now I have problem just with the fourth block, which does not recognize any module: I've tried cleaning again the surface of the I/O contacts but it still does not work..... Smile
How did you solve your problem?
Dear aurelio,
Diego asked me to send him some fotos of the I/O block and he found a corroded spot on it. Using a DMM I could confirm the missing thru-contact. I repaired it using a very small metal piece (from soldering tabs) that I tin-plated and soldered with much caution onto the corroded part of the I/O block to build a bridge across the corroded spot.
Good luck!
Reference URL's