HP Forums

Full Version: HP Prime - problem with Solve App
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everybody, I recently updated my hp prime's firmware and have since been having trouble with using Solve app the way I used to. I used it mainly to solve (non-linear) equation systems e.g 4 eqs involving 4 variables and putting appropriate seed values, then I was given the solution to the system. Now the message "cannot find the solution" keeps appearing no matter what the system is (tried very simple ones to check if I was mistaken). The only way I can use the app now is to check equations with just one variable. Another thing I noticed that is different is that in the Plot view now appears a message "check exactly one equation". I wonder if anyone could help with this problem. I thought of going back to the previous firmware version but I don't know how to do that if possible.

I hope you can help me soon, I'm an engineering student and the app used to be really useful to me. Thanks for your time!

Just a short way down the list is this thread:


(May be of some help).
Ok, I get there is a problem with new version (which I find incredible to happen). Until it is corrected I need to come back to the last version. Is that possible? How should i procede?

Thanks for your time,

I don't know if it possible to downgrade to an earlier version, but there are alternatives to the solve app. Solve(), csolve(), and fsolve(), while more cumbersome, are more powerful than the solve app.
Great piece of advice! I'll go through how to use these functions. Thanks a lot
Internally, the solve app is just doing a "fsolve([<equation_here>,<equation_here>,...],[<var>=<guess>,<var>=<guess>,...])" when there are multiple equations.
Is there a plan to correct this error in a short time?

It is not very useful to have a solver where you can insert 10 equations if you can only solve one at a time. I did it with my 32sII ...

My students had saved the solve app with other names with various equations for electrothecnics, cinematics, dynamics, ...

It does not work anymore. I know you can use solve, fsolve, ..., but you have to rewrite the equations every time...

Go back to the older firmware would not be a solution for me, as the older one can not evaluate correctly the roots of complex numebers.

I don't know if Tim will answer that question, but using fsolve is only a little more trouble than using the solve app.

You can store E0 thru E9 in a list as needed, then typing fsolve(listname,lname(listname)) in CAS get's you the results.


E1: A+B=12/C
E2: (A/B)=-3
E3: C=A*B


list1:={'E1','E2','E3'} // mind the quotes
returns: [−3.77976314968,1.25992104989,−4.7622031559]


edit: An industrious and benevolent soul could even create and app to hijack the input form of the solve app, perform the calculations, and output the results; then share it with the rest of the community.
Interesting approach, road. This worked also:


fsolve("eval(L0),lname(eval(L0))"); ==> [−3.77976314968,1.25992104989,−4.7622031559]

fsolve(eval(L0),lname(eval(L0))); ==> [−3.77976314968,1.25992104989,−4.7622031559]

Even simpler:


fsolve("L1,lname(L1)"); ==> [−3.77976314968,1.25992104989,−4.7622031559]

fsolve(L1,lname(L1)); ==> [−3.77976314968,1.25992104989,−4.7622031559]

In CAS, the same approach, but with csolve, returns:


Which is the exact real solution from fsolve along with the two exact complex solutions. I haven't checked, but I assume the two complex solutions are correct; making this approach much more powerful than the original solve app, which only returns real solutions.

Reference URL's