HP Forums

Full Version: Best method to solve very slightly advanced equations.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I alway seem to struggle with trying to find a correct and reliable way to do various things with this calculator. I've stuck with it since they were initially released and I intend to continue to carry it for daily use once I've finished my degree. The issue that I run into is that there are either not enough detailed instructions published or the methods I find do not work for slightly more advanced problems than those listed in the user's manual, etc.

So, I've manipulated an equation down to the following and I need to solve for alpha without random guesses and 40 different attempts, what is the best method for doing this? I've tried plugging this entire equation in the "Solve" application in various formats but the number it solves for is always about 0.5 to low or high, in which case I probably have an incorrect setting somewhere. I've also tried solve, csolve, and fsolve commands in CAS but I always get [[]] as a result. I'm assuming this is either an error or it's indicating that there are multiple answers, but where do I go from there? I have not been able to find what [[]] actually means.

Here is my equation: (sin(2*a)/(2*pi))-(a/pi)+0.75=0, where a=Greek letter alpha. The correct answer is 1.986 rad = 113.8 degrees.

Please help, thank you!!
Perhaps this has something to do with the choice of variable? I've just tried it, with X instead of alpha, in the Function app (via Plot / Fcn / Root) and Advanced Graphing app (via PoI tracing) and get something around 1.98665…
I just tried it in the Solve app, and it seemed to work for me there too. First I used A as the variable (which worked). Then I used alpha, but I also added "EXPORT alpha;" to the Solve PPL program code (so that alpha would be accepted as a variable). That also worked for me. ("α", not "alpha", in both Solve SYMB and PROGRAM — just to be clear… sorta…)

Have you tried fsolve in the CAS? Since you are looking for a floating point answer.

Hi all, thanks for the quick responses and suggestions.

Let me clarify that I have tried X, x, A, and Greek A (shift, 9, down, enter) all as variables and I either get a bad argument error or the same answer of 2.398 (using Solve). If I put this equation into CAS without any commands it gives 6.928e^-13. solve(), csolve(), and fsolve() with the equation set equal to zero within the brackets all give an output of [[]] (can anyone tell me what this means).

In the Function app/Plot/Fcn/Root gives 0.322 for the root. This morning I reset both A and X within the user variables in memory manager but that did no good.

There have been times in the past where I thought there was something wrong with my calculator, but wiping the memory and installing updated firmware at that time did not improve the outcomes I was getting.

Basically, I really need a calculator solution for solving by iteration, it's a bit cumbersome on the TI-83+ and I hate to keep going back to my twenty y/o calc. for things that should be a breeze on the Prime.


Edit: I did manually push the reset button this morning (which as far as I know will basically do a full restart on the calculator) but got the same results.

Using the virtual calculator when I put this equation in the Function app it shows the roots to be 0. In the advanced graphing app/Trace/POI/X-intercepts is gives 1.986652 but with the same steps on the actual calculator it is still giving me the 2.398 result.

And working through this again I believe that [[]] was telling me that I was not using the function correctly. I also realized that my angles were in degrees instead of radians...so my apologies for wasting everyone's time for a wrong setting on my part. Thanks for your help, I'm now getting the correct result in Solve, Function, Advanced Graphing, and CAS.
For me it works fine with a, calculator set in rad mode.
fsolve in CAS returns the result after a warning screen:

[attachment=3145] [attachment=3146] [attachment=3147]
Sorry folks, it's working now, I had it set to degrees instead of radians. Thanks for your efforts!
Reference URL's