HP Forums

Full Version: HP41 refuses to switch ON after some time OFF
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello All,

I restored an HP41C "Tall keys" not long ago:


I changed the badly corroded flex circuit by one of Diego's replacementes and added 3D printed battery holder, modules and side covers from shapeways. The calculator has been working flawlesly for about two months, but recently it refuses to be powered on after a "long" OFF time (lets say a couple of days). It usually simply does not respond to the ON button, but once it happened that it just beeped. a short beep for every ON press and nothing else.

Pressing clear+ON doesn't seem to change anything, but shorting the battery contacts do; after that it will turn on with a "memory lost" warning, an work normally until it is left OFF again for a long period.

Posts are OK, inside is corrosion free, flex circuit is, obviously, clean and shiny, as are the contact pads. I've not dared to look at the lower end flex circuit, as the control board is held in place by nuts, and I fear to strip the thread, but I'm quite confident the problem doesn't come from it (after all, when "reset" it works normally).

Any experience similar to this? Maybe some electrolythic cap will need replacing? (I feel that those are the most age-affected components, after having repaired several TV's and computer boards just renewing the caps, strangely, all recent models, old ones seem to last longer).
(02-18-2016 09:31 AM)ElectroDuende Wrote: [ -> ]Any experience similar to this?

Just a shot in the dark: I had a 41 with that issue which turned out to have a bad connection to the LCD (and switch) board. Reflowing those connections fixed it.

It was a particularly annoying problem because just disassembling and reassembling the calculator would "fix" it for awhile, so every brainstorm I tried seemed to "work".

(Hopefully Randy will stop by and suggest a more scientific approach!)

Update: Some good suggestions from Geoff and Den in this thread
I had a 41CV fullnut with a similar problem which went away when I installed a new battery holder. I think the issue may have been creeping oxidation on the battery springs. Did you reuse the battery springs or get new ones?

Regarding the nuts, you should be safe if you are careful to engage the same threads rather than cutting new ones when you reinstall them. I have one 41C where one of the nuts was not tight enough from the factory. Removing the nuts, I could see that the threads weren't cut as far down on one side. You could check for this by pressing down on the CPU board and making sure there are no gaps between the board and nuts.
The nuts were self tapping.

They were a one time thing according to HP. When they repaired or replaced the main PCA they scrapped the nuts and included spacers which compressed the PCA into the lower keyboard PCA contact points using the bottom screws as the compression force.

You can fashion the spacers out of silicon tubing or white plastic model tubing. The white plastic tube can be found at the model supply shop in a diameter which tightly fits over the screw post and serves to reinforce the post.

1 Top screw post reinforcers, must mill some of the battery/module block.
2 bottom screw post reinforcers and compression aids if screw post threads stripped.
3 HP nut replacement spacers found in repaired full nut HP41 C pre 1981.

[Image: 2newcompressionreinforcements.jpg]

In place on a 1979 HP41 C with board installed.

[Image: 1hpfix.jpg]
Reference URL's