HP Forums

Full Version: Strangely behaving 16c
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Howdy all. I just picked a 16c up off of ebay. The problem is that it does not behave as I would expect. For example any multiplication seems to have the last 4 bits masked off of the result. So 15 3 * produces 32 instead of 45. Every product have tried has had this same peculiar defect.

I have tried a reset with [-] + [on] as well as shorting the battery terminals but the issue persists. I am new to the 16c so I suppose there could be some masking mode that is turned on, but a skim of the manual has provided no clues.

Another issue is that I cant seem to run programs. even when entered from the manual keystroke for keystroke I just get a error 4 every time.

A couple of things concern me about this purchase. One, the unit is in shockingly good physical condition. Two, the keys feel slightly mushier than I would have expected especially the enter key. The other keys are close enough to the hp keys I am used to (hp 48) that I would be satisfied, but the enter key feels awful. Very stiff with no real snap to it. Are counterfeit voyagers a thing? Other than those two concerns and the odd behavior everything looks legit to my admittedly untrained eye.

Any help would be appreciated
Welcome to this forum.

You didn't mention it, but a self test check would make sense in this case.
Details here on the notes at the end of the page and here.

Yes, I did forget to mention it. The self check passed with no complaints and ended with all segments active.
What about the keyboard test (using the divide key) ?
A stuck key could create all sort of issues.
Did not know about the keyboard test. It too has passed displaying 16 in the middle of the screen.
I have no physical HP-16C with me, but one can check it by using a emulator, for instance this one.

Did you try to store a simple integer decimal number to memory (for instance: 25 STO 0, then RCL 0) to check the ability of the calculator to use the memory cells?
You may have found me the core issue! Addresses 0 and E seem to work fine, but addresses 1-D and F only return 0! Is this a common failure mode?
I have a few 11C and 15C's, but not the 16C (not yet...), and have been lucky so far.

In your case, it seems that some memory cells are not able to store information.

I have read some reports elsewhere concerning malfunction when using depleted batteries, but also when using fresh batteries (!).

I would try first with fresh batteries (1.5 Volt per cell), and then look for some depleted batteries (1.3 Volt per cell) and see it makes a difference.
that is a good idea. I will try some different batteries before I initiate a return with ebay. Thanks for the help.
(11-19-2015 10:50 PM)Taco Sundae Wrote: [ -> ]that is a good idea. I will try some different batteries before I initiate a return with ebay. Thanks for the help.

Make sure to short the battery contacts together for a few seconds before you install the replacement cells. This will guarantee that the CPU gets a real reset.
Hi! do you have any news on your calculator? Otherwise, i would be interested in buying it from you. Did it work with new batteries?
A bit late however your problem simply is you have the wrong word size selected?
This would give erroneous results.
However a reset should set it back to 16 bits...
The last time the OP signed-in here was 2 days after his/her initial post in 2015, so there's probably not much point in looking for any kind of reply...
Reference URL's