HP Forums

Full Version: Bricked Prime during update last night HELP!!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
On Tuesday September 2, I tried to update my Prime to the new software via the connectivity kit. It got about 75% complete and it gave a error code of 104 and then started to give repeated fail messages. Now the Prime turns on, boots to the "x^2+y^2=1 screen, hangs there for a few seconds, and then reboots itself. I have reset it using the pin in the back, used numerous code combinations that I found on the forums for clearing the memory and nothing has worked.

It took me two days to find the HP calculator support (I guess HP is splitting??) anyways the guy tried to assist, but told me to do stuff I have already done. Eventually it then came down to when I had purchased it. Which was through Amazon more than 12 months ago. When I told him that he basically through me to the wolves and said he couldn't help and I would have to buy another one!!!!??!?!?! I was absolutely astonished at this. What about a repair option? I just didn't see it as my fault the update failed and I am now left with a $140 calculator that is worthless. I was never treated this way by TI, even when I spilled a drink on my 89 and had to send it in for a replacement. I was charged 30 dollars and got a new one back within a week. What gives here?

So lesson learn here, be cautious on updating your Prime, because if something goes wrong and it bricks, HP says you SOL.

For those who may need to contact HP for calculator support here is the info:

(and yes that email address is the one i was given)
Thanks for the reply. That thread got me passed the loop it was doing. Now it keeps doing this:

[Image: FullSizeRender1_zpszhmk48wr.jpg]
Have you tried reformating the internal storage ? Simultaneously hold down C F O then On, and the calculator will boot into its utility setup mode. Select option 4. FLS Utility, then 3. Format Disk C. When done, back out and select 9. Reset, and the calculator will reboot into its normal mode.

This might not help, but the only harm will be the loss of all your programs and data.
"unknown command: a2." could also point to a transfer error.

It's very hard to completely brick a Prime, beyond repair by the maintenance menu.
(09-05-2015 04:52 PM)neomist Wrote: [ -> ]So lesson learn here, be cautious on updating your Prime (...)

Yes, several issues are related to the USB port used to do the updates.

I would recommend anyone with these issues to try another computer with:
- A powered USB v2 port (do not use a hub device);
- Run a trusted Windows version (like Windows 7 or Windows 8.1) natively installed on the computer (do not use virtualization at this stage).

Good luck with your calculator, and keep posting here your findings.
(09-05-2015 06:44 PM)neomist Wrote: [ -> ]Thanks for the reply. That thread got me passed the loop it was doing. Now it


Sorry you're having trouble. Three things here I'd comment on:

1. Are you using a virtual machine, or a native windows machine? Some virtual machine software works fine, while I've seen others cause trouble.

2. Are you conneting directly to the computer, or through a hub or another device? I've seen this cause a failure before for at least 1 person.

3. Have you tried any other cable? Again, another user had a bad cable and changing to another immediately worked.
Interestingly, I encountered this same problem when updated the firmware on my daughter's Prime. I got about 50% through when Windows 7 wanted to update the USB driver, or something like that. Anyway, it ruined the connection with the Prime. It would flash "HP" and then reset and flash "HP' and reset and so on. It was a bit disconcerting. After my first attempt at a reset, my connection screen looked like the one you posted. I eventually was able to get past it. Here's what I did:

1. Press and hold the Symb key
2. Press the reset button (through the little hole in the back) (I used a thumbtack).
3. Release the Symb key
4. Remove the little tack I used to press the reset button.

Once I did this, it returned to the connection screen in "recovery mode". So, at this point I was able to have it connect back to the PC where I used the HP Connectivity Kit to complete the firmware update. I think this is essentially same instructions as in the link earlier in the thread. Here's a link to another site that I found useful: https://www.educalc.net/2336439.page .

Now, everything seems to work properly.

Hope this helps.
I had that problem last night and found a solution on the Web.

Hold the SYMB key down reset with a pin at the back of the calculator and then while still holding SYMB key plug the USB cable to your pc and ConnKit will recognize it and initiate the Firmware upgrade.
Reference URL's