HP Forums

Full Version: Equation in solve app not solving
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I put an equation into the Solve app- E1-

L= (P)* (1- (1/(1+R)^N))/R

Then put numerical values into L,P,R and tried to solve for N. I did this by pressing the Num key on the calculator then first pressing Blue-Shift clear to zero out anything in the variables then entering values. Then highlighted the value I wanted to solve for and pressed Solve then nothing happened.
It remained 0 (incorrectly).

Am I missing something here?
Which variable? What values did you enter?
The formula will solve for N with the appropriate guess values for the other variables. By clearing out all of the variables to zero, you will always get a "Bad Guess" error.
For example: L = 100, P = 50, R = 0.25 and solving for N gives N = 3.10628...
Unfortunately it seems the solver app doesn't work right. I used eg L=100000 P=2000 R= 0.00281, tried to solve for N and nothing happened. Then I used my HP 50 and got the correct result (N=53.95...). I tried several other values as well, but the result doesn't come up correctly on the Prime?
Works fine for me in the solve app (53.956...). Version 6975.

What are your home settings? Did you try fsolve?
The same here. In actually, this is one of the few areas where the Prime outperforms the 50g.
Changed integers setting in Home Settings to Binary (was some other value before) and it works! Thanks.

PS subsequently also checked the digit grouping Setting in Home--looks like the , (comma) used for thousand place holder was giving me this error.
Reference URL's