HP Forums

Full Version: Spreadsheet - Strange Content
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
After working some time with the spreadsheet and transfering between the emulator and the calculator it shows


in lots of previously empty cells. In my case E1 to ZZ4.
When entering a number into the cell and deleting it again, the same shows up again.

Is it somehow possible to get rid of this strange content?

Many greetings
in the entry line:
Thank you,
I think I'm missing something. When entering E1:={{}} somewhere in the spreadsheet I get {{}} as a result in E1. Deleting leads to the same strange content of E1.

my fault. the double colon is wrong.
E1:ZZ4:={{}} should to it.
If you want to erase only one row or one column, e.g. E1:E4, or E1:ZZ1, use {}
Don't enter this in a cell, use the "entry line".

If you want to erase a single cell, like E1, use the Backspace or [<X ] key, directly below 'CAS'.
Otherwise the contents you mentioned is really strange.
If the mentioned steps don't work, you could reset the spreadsheet by using Shift Esc (labeled 'Clear').
Thank you,
writing a number to E5 and typing E1:ZZ5:={{}} shows that it in principle deletes something (the content of E5) but E1:ZZ5 still contain the strange content.
So maybe this is the third bug in three day I found in the spreadsheet. Quite Disappointing.


Edit: Hitting delete of course does no delete the crap in the cell... It only brings it back after something else was in the cell. And I will for sure not clear the spreadsheet to lose my content.
Edit2: Same result for E1:ZZ5:={} ... deleting content, but not crap.
Have a look at
Maybe there are more hints & tips.

I don't think, that this is a general bug in the spreadsheet.
What did you do exactly before you've got the entries "-:.00000>:000e-369098747" ?

You could also copy the relevant content to a matrix (see http://h30499.www3.hp.com/t5/Calculators...192#M14642) , reset the spreadsheet (or create a copy of the spreadsheet), and copy your data back to a fresh spreadsheet.
There is another possible reason for the weird contents:
The data could be entered & stored to the complete row!
If you select for example the row 2, and enter something ("test"), this will be stored to all (empty) cells in row 2.
To delete this entries, select row 2, and press backspace.
Individual contents of single cells is still remaining, but "global" contents of the row will be erased.
Hello Thomas,
I've given up.

Thank you very much for all your effort
Have you tried my last suggestion?
(Select entire row, (in your case 1, 2, 3, 4) press Backspace)?
Hello Thomas,
yes, I did. Moved the cursor into the row-number-column, pressed <x-key. Well, didn't help. Rebuild the table, deleted the old one.

Thank you very much, viele Grüße
Sorry for this bug.

Hopefully someone related to HP should read and answer.

greetings from Erlangen,
(03-23-2015 06:39 AM)Thomas_Sch Wrote: [ -> ]Sorry for this bug.

Hopefully someone related to HP should read and answer.

greetings from Erlangen,

Saying sorry makes it sound like you're responsible for the bug - which I don't think is really the case.
Hello guys from HP (Tim, Cyrille, Parisse, ..),
any comments ?

Is this a bug, what do you mean (or know) ;-) ?

This strange "content" is how a "bad" real will display (your mileage will vary depending on your value of "bad").

This means that the memory was corrupted, somehow.

Since I am perfection incarnated, it could not have been my programming, so the memory corruption has to have been caused by some "act of God" (insurance definition thereof). Have you been in a place with a high level of cosmic radiation lately? Smile

So, what can you do?
Well, corrupted memory, usually means that the device is likely to crash at one point in the session where the memory was corrupted.
Interestingly enough once corrupted memory gets saved to file and reloaded, the data stays corrupted, but the memory structure itself is NOT corrupted anymore!

So, let us look at the possible cases:
1) Memory is good, Some data is in spreadsheet in RAM, Some data is in spreadsheet in Flash.
- Reboot means loosing data in RAM (Flash data remains)
2) Memory is corrupted, Spreadsheet data in RAM is corrupted. Calculator will crash at one point.
- If you can SAVE the corrupted RAM data in Flash, AND if a subsequent reload does not Crash, you will end up with a NON corrupted memory, BUT Spreadsheeet content containing BOTH corrupted AND uncorrupted data...
3) Calculator crashed, spreadsheet DID reload (ouf!)
- You have ALL your DATA + corrupted stuff

1) is the normal state.
2) is bad as you will loose data in case of reboot/crash.
3) is "good" as your data is NOT lost. All you need to do is erase the crud.

So, obviously, what you want to do is go from step 2 to step 3 so that you can cleanup the "mess".

To do that, turn the calc OFF (which saved all the files to Flash), turn it back on and reboot (ON+Symb). This places you in step 3 (if all goes well), at which point you can recup your data if all goes well.

I am sorry to hear that this is happening to you. If you can find a reliable way to reproduce it, please do tell me!

Hello Cyrille,
thank you very much for your effort. After rebuilding the table it did not happen again. Since I'm a novice using the prime I might do strange things and managed to crash the device two or three times. Thus, if I manage to reproduce it, I'll tell you.

By the way:
Quote: 'Have you been in a place with a high level of cosmic radiation lately?'
The natural radiation level here is 2.2µSv/day.

Reference URL's