HP Forums

Full Version: No UNROT on the HP-48G ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
It's been a while since I wrote any program on the 48 (been on 50G and Prime and busy with my new HP-67)

I cannot find the UNROT command on the 48. I thought the RPL was the same between the 48G and 50G. I know the 50G has a lot of additional commands but I find UNROT pretty basic not to be included on the 48G.

For the time being I use ROT ROT instead unless anybody has a better suggestion.

Fran├žois
That's right, the 48 does not have an UNROT command in its User RPL command set. It IS available in System RPL, however. For User RPL programs, ROT ROT or 3. ROLLD are equivalent to UNROT.

The other 50g stack commands not in the 48 are: DUPDUP, UNPICK, NIP, and NDUPN.
<< ROT ROT >> 'UNROT' STO

Problem solved Smile
(11-01-2014 08:17 AM)Paul Dale Wrote: [ -> ]<< ROT ROT >> 'UNROT' STO

Problem solved Smile

Or (using the "hidden" UNROT command):

<< # 397228d SYSEVAL >> 'UNROT' STO

But this one is restricted to the 48G/GX. So don't try this on a 49G/49g+/50g...
Reference URL's