HP Forums

Full Version: possible bug when dividing in Home
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
when i enter the following equation in Home Mode, the last division captures two terms instead of just one term causing a calculator error

0 = D*3/5 -(E + C *3) / 6.708

what I should get is

0 = D*3/5 - E + C*3/6.708

if I enter the same equation in CAS Mode in small letters, no problem, but when I enter the same problem in CAS Mode in Capital Letters, I get the same error that occurs in the Home Mode. I know there is an easy work around, just use parenthesis, but it is still a bug that needs to be fixed.. I discovered this bug during a test so I got a wrong answer, not a good time to discover bugs. Note: when I enter the equation I am not using parenthesis, the above example is what the HP Primes does with the equation after I divide by 6.708
Sorry to hear about that. Were you typing in 2D mode and just didn't spot that before evaluation?

Interestingly, the issue seems to be the use of the E variable. If you change it to 'F' it behaves like you expect. I wonder if for some reason it is interpreting that E as part of an exponent or something...

PM me if you'd like me to call or email the teacher/professor and talk with them. :-)
I couldn't reproduce the behavior on my device (6030). I tried with or without digit grouping as well as with or without textbook display. I even tried to add spaces in the same places as indicated in the opening post. The expression comes out in the history correctly. The result is always 1 because on my calculator, C, D and E are zero.
You can reproduce it without the spaces while operating in any 2d mode (textbook mode, or RPN with a ' '). Just [ALPHA] [E] [+] [5] [/] will do it. Definitely has to do with thinking the E is part of an exponent.

That division node is the trickiest and most difficult one in the whole system due to way you have to grab preceding content intelligently in order to convert prior stuff into content above a fraction bar. There are a lot of special cases and looks like this one slipped by the person who wrote it.
(07-18-2014 04:04 PM)Tim Wessman Wrote: [ -> ]You can reproduce it without the spaces while operating in any 2d mode
That explains it. I was using algebraic entry.
Reference URL's