HP Forums

Full Version: Backup does not work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I tried backup of HP Prime Calculator and HP Connectivity Kit also but it does not work. I have last official version and HP Prime Calculator G2 rev.D. After backup Calculator and Restore I can see only "Clearing memory" with hourglass and calculator freeze. After backup (backup.zip) and restore Calculator trough HP Connectivity Kit is totally cleared Calculator and data and programs are empty. Do you have anybody this problem?
It seems, I'm the only one with the trash...
No, you are not alone :-)
Same hardware, comparable problem. Restore of local backup causes immediate
reboot with empty memory. So local backup is useless ! Backup via USB works.
Regards Andreas
Can you please send me the faulty backup file?
I do not seem to have the issue here.

Here is my USB backup. I tried internal backup calculator after reset, it does not work too.

Could you please be a little bit more precise as to what you are doing and what is not working.
I tried restoring your backup on a G2 and on an emulator, and had no issues doing so.
I tried doing a backup on a physical calculator and then restoring it and had no issues...

I just want to make sure that I can reproduce the problem so I can fix it.

Backup internal:

1. I open Memory Manager
2. I tap Backups, and then tap New and it creates a new backup file.
3. I restore the HP Prime calculator using the selected backup file and after that calculator freeze.

Backup external with connectivity kit:

After the HP Prime calculator appears by name in the calculator pane, right-click the name of the HP Prime calculator to open its context-sensitive menu. I choose Backup and backup the calculator to my MacBook computer (zip file).
I choose to Restore the calculator from a backup zip ƭile and the calculator is restarted and is totally cleared. The calculator is in factory settings.

Thank you for your help
Internal backup propose name Backup 2021 4 28. I rename it to Backup_2021_2_28 and now it Restore works! Smile
Hello Cyrille,
with the update of the calcs firmware to the new beta (2021-04-28) even the old backup via USB no longer works. The calc reboots immediately with cleared memory.
I have downgraded again to the old official version (2020-01-21) and at least the USB backup works again and restores memory ok. The zip-file is attached. Trying a local backup on the calc always ends with a cleared reboot as stated earlier.
Thanks a lot for your effort.
Reference URL's