HP Forums

Full Version: BUG with e^x in CAS in program
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
This prgm. is just to illustrate the problem.
EXPORT test1(f,v)
BEGIN
diff(f,v);
END;
As soon as I have f with e^x and execute the test1 I get "Error: Bad argument type". For any other f ex. test1(2*x+5*x^3,x) I get the correct ans. 15*x^2+4*x. For test1(2*e^(2*x),x) I get "Error: Bad argument type" and for test1("2*e^(2*x)","x") I get 2*2*e, the 2*x disappeared. On the command line, in CAS mode, everything seams to work OK and that is why I think there is a BUG in HP Prime.
Could you please elaborate how you are making this and where you are calling it from?
(06-13-2014 02:39 PM)Tim Wessman Wrote: [ -> ]Could you please elaborate how you are making this and where you are calling it from?

Yes I can. The program to ilustrate the problem is also in my previous post:
EXPORT test1(f,v)
BEGIN
diff(f,v);
END;
I run this program in CAS mode. All functions of f(x) that do not include the exponential function ?*e^(?*x) as an argument to test1 seam to give the correct answer and run without error. As soon as f(x) includes e^x the prog1 gives me the error "Error: Bad argument type". The same f(x) run in CAS on command line ex. diff(x*a*e^(b*x^s),x) gives the correct answer and no problems. Only f(x) with exponential function as an argument to prog1() gives the error. For me it looks like in program environment there is some kind of problem accepting e^(x) included in argument.
Reference URL's