HP Forums

Full Version: HP PRIME horribly bricked during update ? (SOLVED!!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I'm pretty shocked, since I've been updating other calcs tons of times and this is the first time it happened to me...so a little challenge for you gentlemans, and a (very ) small hope for me.

HP Prime

Software Version: 2014 12 3 (6975)
Hardware Version : A
CAS Version: 1.1.2-11
S/N : 4CY342080X
Operating System :SDKV0.44_R.521

Charged for 5 hours straight before updating.

1) Put into recovery mode ( V13) and connected to HP Connectivity Kit 2.1.14425 ( 2020 1 16)
2) the Connectivity Kit asked me if I wanted to update the Calculator, answered yes
3) 2-3 stages of transferring and loading ( could see the progress bar going parallel on the Calculator AND on the PC screen)

- At the end of, I believe, 3rd stage, maybe it was the ROM's, the screen went totally black.
- Waited 2-3 minutes then tried to power on the calculator with no result, screen always black, no sign of life.
- Unmounted the battery to check the charge and I still measured 3.9 V; waited 30 seconds before inserting it again in the calculator, but no sign of life, only a black screen.

Tried C+F+O and paper clip, with no result.

Can you please guide me on how to recover from this situation, ( if possible, of course)..? I'm pretty sure everything went as it was supposed to, except for the final unexpected result...

Thank you


I know my hope is hanging by a thread, but I did some experiment I wanted to write about.

1) Kept the Prime without battery for a couple of hours to discharge a possible residual charge from the capacitors, then insert it again : no change.

2) When plugging the Prime to the power supply there are two cases :

A) With the battery : nothing happen at all, not even plugging or unplugging the prime from the power cord.
B) Without battery : by plugging the power cord, the screen just "flash" for a tenth of a second, like it was trying to start, then return black again.

That's all folks...hopefully someone can pull a rabbit out of a hat...


In despair, I ordered a new battery from Amazon, although I measured the original's charge with a Fluke instrument and it was 3.9 V

P.S. 2 :

Tried also :
1) Press ON+Apps+Esc.
2) Press ON+Symb.
3) Press keys ... C+F+O simultaneously and ON key

No change.. :-(
I write here the solution, so that maybe someone else in the same situation, can understand the steps to solve the problem.

I found a post on a forum, written by one of the head developer of the Prime project : to solve another problem ( partial update ) he suggested to press "Symb", press the button on the back with a pin, and release the pin.

It WORKED !! I was able to return again in Recovery mode (v13).

At this point I tried at least three times to update the Prime but the result was always a final black screen and a calc that didn't turn "ON"...
Changed USB port and reboot...again update but same result.

At this point, I changed PC, and did the same update process and...after the update, instead of staying black, the Prime booted up with the initial setup !!

I think something on the first PC USB's was preventing a final "acknowledge" to the Prime, so that the process was truncated prematurely after copying the three files that are part of the new firmware.

Changed PC, and everything went smooth.

Sorry for bothering you all people
It's no bother... but thank you for sticking with it and solving the problem and especially for taking the time to document here how you solved the problem, which will hopefully help out the next person with similar issues to resolve their problem.
(11-09-2020 04:26 AM)rprosperi Wrote: [ -> ]It's no bother... but thank you for sticking with it and solving the problem and especially for taking the time to document here how you solved the problem

Glad of being of help, hopefully..


Reference URL's