HP Forums

Full Version: Apssman Library Use
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I came across the Appsman library when reading the information from the EQL + library of the remembered professor Wolfang Rautenberg, excellent programmer of many of the most useful programs for our HP 48G-GX-50g. But I don't quite understand how to use the Appsman library, because in the help it says that you have to configure the reserved variables APAR, APAR1, APAR2, etc; and in the examples that have the help it is not clear how I assign the value to each of those variables, for example if I want to assign the list {11 4 2} to customize the APPS application box and create the APPAR variable and then press the STO command to store this value in the variable and also leave the USR mode fixed (the user mode) as the help says, absolutely nothing happens, the APPS menu continues to come out complete with all the options as from the factory.

The application is at this link https://www.hpcalc.org/details/4593.

The reserved variable APAR does not appear in the HP 50g advanced user manual either, so I do not understand how its value is modified to make the Appsman application work.
Did you attach the library provided and were you in USR mode? Although it does not use key assignments, this is only active when USR mode is active.
Yes correct, I did. But how do you configure the values of those reserved variables APAR, APAR1, APAR2, etc? If I keep a list like the one I put above with 11,4 and 2 in a variable called APAR in single quotes, the variable is created but has no influence on the APPS menu. Nothing happens. The only thing that appears when I enter the library is INFO, which by pressing it tells me some information about those variables but does not say how they are configured
Have you already read the manual? It is available online and should be also included in the archive.

I just tried this in a 50g with the latest ROM (2.15) and it seems to be working fine.

I installed the library in Port-0 and then simply did this:

{11 4 2}
[LS]-[ALPHA] to be sure USR mode is on
[APPS] => The Apps list only shows CAS Menu, Numeric Solver and I/O functions, just as shown in the Appman docs.

Purging 'APAR' restores the default APP menu

Re-reading your OP closely, you mention the variable APPAR, however the docs refer to the variable APAR. Maybe it's that simple?

Let me know if the above doesn't work.
Thanks for responding rprosperi. Yes, I have already read the online manual about 3 times, but I do not understand why it does not work for me. I have the latest version of the system, 2.15 as well, and I have installed the library on port 2, 1 and 0 and neither works. I did the steps as you say: I installed it on port 0, then I wrote the list {11 4 2}, I wrote it in APAR quotes and gave it STO, then the APAR variable is created in the HOME menu and being in the User mode, USR, you I give the APPS key, and I get the ENTIRE full menu, just like always. Does any special flag have to be activated?
I don't think any special flags/modes are required. I tested using a basically empty 50g I keep handy for checking things like this; since the Appsman Library only works in USR mode I could not use one of my normal (*) machines, which has a lot of non-std settings.

Did you try this again with 'APAR' (and not APPAR as listed initially)?

Can you verify that the Appsman Library is indeed loaded in Port-0? If you use Filer and navigate to Port-0:IRAM, do you see the Appsman Library, L1791 ?

The instructions don't mention other exotic settings so it's probably something basic.

* On my 'normal' 50g configuration I have the APPS key defined to be a menu toggle, selecting between the Development Library (256) and the Stack Menu (a super-handy assignment courtesy of Joe Horn; ideal for 'couch hacking')
Yes correct To the browser with the filer, the library is installed saved on port 0, in addition to the variable that it creates is 'APAR', and I have the user mode blocked with a single time of LS and the ALPHA key so as not to be pressing 2 times the key combination. And by pressing the APPS key, full sale! I do not understand what it can be, or if any library is bothering or has any incompatibility.
Troubleshooting library conflicts can be troublesome. If the problem is a library conflict, you may have to remove the other libraries to see if the problem is cleared.

What other libraries do you have installed? Is Keyman+ installed, that comes to mind as one that can affect key behavior?
The problem still persists. I did have the Keysman library installed, and also Mr. Wolfang's EQL +, and when I see the library numbers I realize that this APPsman library has the number 1791, that number also had another help library that does not appear the name, I think that HLP 1791 from 2000 is helpful but I uninstalled it, I also removed keyman and HPLibman as well and nothing. I'm going to uninstall all the libraries to see which one may be bothering. I have others like Tim Wessman's PEQUM, but I don't understand what it can be. The doubt I have is that the manual says that the APAR variable is reserved, but it does not exist in the factory calculator because I am creating it when I save it a list like {11 4 2}, I do not understand how the calculator is going to read that there is a created variable called APAR and simply make that when pressing the APPS key that variable is called, in the same way it could create 10 different variables with different names and when pressing APPS those variables will not be called, what is it? what makes the APPS key call the APAR variable and read its contents and then customize accordingly? In some way they have to be related, such as that on the user keyboard one has stored a key that when touched in user mode calls the contents of the APAR variable, but that is not done in the manual.
Hello rprosperi ... EUREKA! as Archimedes would say .... I have succeeded! But I don't know what the problem was, what I did was that for lack of patience I eliminated all the other libraries that I had installed, then the user key assignments, also the APAR variable that I had created and finally I gave it CLEARING THE MEMORY with ON + F1 + F6 and set it to not recover anything, I left the calculator as factory. Then I did the steps that you put to the letter, and I put the calculator in user mode with a single press RS + ALPHA and it did not work, then I put it with two keys locked RS + ALPHA + RS + ALPHA so that it is in USR, and it worked, I get exactly only the three options on the list! Thank you very much for your time, now I will be installing the libraries one by one and test if any of them affects the operation of APPsman. Thanks again.
It means that the library works with flag 61, it must be activated so that the keyboard is fixed in USR and APPsman works and this has been done before, the strange thing is which other library there was conflict with. I will try to find out by installing the ones I had before.
(08-02-2020 06:57 AM)SammysHP Wrote: [ -> ]Have you already read the manual? It is available online and should be also included in the archive.


Yes the manual I already read it too. I don't know why but when uninstalling all the libraries it worked, some of them was the culprit!
(08-03-2020 04:03 PM)math7 Wrote: [ -> ]It means that the library works with flag 61, it must be activated so that the keyboard is fixed in USR and APPsman works and this has been done before, the strange thing is which other library there was conflict with. I will try to find out by installing the ones I had before.

Yes, I checked it with Sys FLag 61 SET and CLEAR and this does not affect Appsman, so it must be some library conflict. If there were another library installed with the same library number, I would strongly suspect that is the cause; in such case, the installing sequence (which library was installed first/last) probably is the reason. This is probably a good place to start checking.

Good luck and please report the conflict, once you find it.
I already found the cause of the problem causing APPsman library to be disabled. The conflict occurs when the APPNUM 2.0 library is installed at the same time at this link


I don't know why this will happen, but when this library is installed, APPsman doesn't work, and when uninstalling APPNUM, APPsman already works. The APPNUM 2.0 library is from an excellent programmer César Vásquez Alvarado who made many excellent programs for the HP 50g in System RPL, but for some reason creates a conflict with APPsman, one would have to know the source code to see what the reason is.
Wow, I agree that's really quite unexpected and quite strange.

I don't read Spanish, so can't get all the details from looking at the included text file, but it does not appear to use the same library # as Appsman, so should not conflict. Also, a numerical integration program should have nothing to do with manipulating reserved variables, etc. Quite strange, but thanks for taking the time to find the conflict and report it here.
Oh, it's nothing. We are here to help us. Yes it is strange, but since the APPNUM 2.0 library is made in SystemRPL I suppose that somehow it internally deactivates something that has to do with the USR mode with which the APPsman library operates.
Reference URL's