HP Forums

Full Version: Weird problem in HP 20S
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm facing a very (VERY) weird problem in a HP 20S I'm trying to repair.

I bought it defective, some keys not working. I must confess that I didn't test it thoroughly before opening the case, I was very confident it was the aged rubber pressing keyboard contacts. So I opened it right away.

It was very dirty, pcb solder was very oxidized, so used a very delicate soldering iron to redo all soldering pads of the processor (I'm experienced on SMD soldering), and I'm sure there are no shorts or any other problems. Then I thoroughly washed the pcb with isopropyl alchool. It looks like a new PCB now, and looks perfect after detailed examination in the microscope.

Well, after cleaning the case, LCD, zebra strips, and replacing the keyboard rubber, I reinstalled the LCD and PCB, pressing it down with some clamps (to avoid stress on the twist tabs for now), and now the calculator works for a few keystrokes, and then the keyboard dies completely. If I short the battery contacts, it resets and works for a few more keystrokes, and stops again. Then I tried again, but waiting 10 seconds before hitting any key, same result, so it's not the keystrokes that freezes it, it's time after power up. I have no idea of what to do!

Some more information:
- I can't confirm if the calculator freezes, or only the keyboard stops working. So it may be a keyboard, PCB or processor issue.
- If I use this same PCB in another Pioneer shell, the same problem happens, so I can conclude the keyboard is ok.
- If I use the 20S keyboard with a 32SII PCB, it works perfectly, so I can be very sure the keyboard is not the problem
- This 20S is an older model, serial 3031B92619
- I tried with another HP 20S LCD and zebra strips, and the problem remains unchanged.

One interesting point: if I power up the PCB with no keyboard and no Pioneer sheel (pressing the LCD with my fingers), using an external power supply, I can use a metal wire to short keyboard pads, to simulate keystrokes, and this way the calculator remains working for several minutes with no problems. The "freezing after some seconds" goes completely away!

I have a theory, that something in the shell may be shorting something in the PCB, that may be seen by the processor as a stuck key, or something similar. However, I examined very carefully how the PCB touches the shell, and I can't see how a short could possibly happen.

Another similar theory is the creation of a capacitance or something like that, between two very close metal parts and/or PCB tracks, creating the same stuck key effect.

These theories relate to the fact the PCB works ok outside the Pioneer shell!

Well, this is the problem, I never seen anything like that, and any idea on why this is happening is very welcome.

Thank you all!

In doing similar repairs I found that the PCB pads at each twist post are not necessarily tied together on the PCB itself. All the pads are supposed to be ground and the metal plate and twist posts are connected to battery negative. Try closing all the twist posts and see if that might restore operation. Part of the PCB circuitry might be floating with respect to ground or getting a weird path to ground via some other component.
Thanks for the insight, it makes a lot of sense! I did twist the all 6 posts, but the calculator still doesn't work. I think I'll put it aside for now and try the next one (I have a number of Pioneers to restore), but soon I'll be back to this old 20S.

However, I have found an interesting piece of info here:


It says open switches with leakage below 10Mohms may cause processor lock ups, exactly what I seem to be experiencing. I'll keep trying, thank you very much!

Two possibilities:

1) Leakage on the processor board between keyboard lines. A common cause is corrosion that did not get cleaned away with the resoldering of the processor board.

2) Bad bypass cap. I would replace the 10uf tantalum capacitor on the board, if it’s esr has gone high, strange behavior will result.
Reference URL's