HP Forums

Full Version: Connectivity Kit grief
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello all,

The Connectivity Kit under "normal" conditions seems to work just fine. My situation might not qualify as a "normal" condition, but hoping someone has some helpful suggestions if they have experienced similar.

The problem: An app that is fairly large at ~2MB, is installed on a HP Prime calculator (G1). Installation works fine the first time around. After some time I want to add a file to the app's files or I want to update the app to a newer version, or I simply want to connect for any other reason to the Connectivity Kit. The calculator is plugged in, then when attempting to "expand" the calculator in the Connectivity Kit; the "insufficient Memory" error pops up on the calculator. Ok, now what? Sometimes ON+Symb will do the trick and it works afterwards. This is not always the case, and the only way to get the connection happening again is by deleting the large app. Of course this is very frustrating as there are variables and files associated with the app which I'd rather not lose.

Things I've tried:
- Reduce memory size of the app so that certain resources are actually stored as list objects (L1-L9) and are not part of the app program code. This has not helped.
- Created a method to move all app variables to an HVars container temporarily. After this I can delete the app, do whatever I need to do with the Connectivity Kit, then reinstall the app and run a program to restore the app variables from the HVars container. This does not take care of any files that are inside the app folder, but at least the variables.

To me it just doesn't make sense why this is so damn hard to get a simple file transfer completed when a larger than normal app is installed. I see on hpcalc.org that in the past others had created alternate tools (libhpcalcs and PrimeComm) to address issues at the time (2013/2014). Those programs no longer work it appears. Has anyone done anything on this front with recent firmware? There must be a better way, I have a hard time believing that the issues I'm having are actually hardware limitations that cannot be solved.

Any thoughts or experiences?
I have heard from user reports that the G2 hardware is not quite as problematic. Still, I would have thought that technically the G1 would not have a problem with a 2MB app. The burning question remains if the problems are due to artificial limitations or hardware limitations. And are the problems specific to a a single file or sum total of all user created content.
Reference URL's