HP Forums

Full Version: Understanding CAS variables
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I recently switched over from the TI NSPIRE series to the HP Prime and for the most part have been finding it a very similar experience. However I've been having issues with the variable system of the CAS environment, which may be due to a misunderstanding of how to use it, or a conflict with other apps. Here is a screenshot of what I'm talking about:
[Image: IMG-20190307-113841.jpg]
So to summarize the photo:
entering something like:
e^a [enter]
returns 1
as would e^(a+b), but e^g returns e^g
All of my variables when viewed in the memory manager are listed as (Real). I've tried purging the variables but get the message "no such variable a". I've also tried resetting the variables with mem->User Variables -> reset, but that gives the same result. Also, I did notice if I do solve(a^2+a*b-1 = 0, a) it returns {-1,1}, so solve seems to work correctly.

I have an equation library app (EE Library) installed that contains a ton of variables so is the issue related to the App defining all variables including the standard single letter ones or does resetting them all redifine them as = 0 and I'm just using the variables wrong?

Semi-Related question: Is there a way to quit out of apps like on the NSpire where ctrl-w or esc would usually quit? I noticed whatever the last app i had running the name always stays at the top, so does this mean its running in the background/ still has control of things like the variables when i go back to CAS?

Thanks in advance for any help you can Provide!

Edit: link to image since the embedded image seems to not be working
Edit 2: fixed embedded image
See if you are still getting the same behavior while using a default app (e.g. the Function app).

Chances are, you are inside an app that has pre-defined some of the variables you are trying to use. Such variables cannot be deleted/purged by the user as they are tied to the app themselves.

(PS: I was not able to view your screenshot at the time of this post)
Han, thank you for the info, I tried it with the function app and it still has the same behavior unless I'm using something like solve(e^a=5,a) (returns ln{5}). Anything that isn't the variable variable I'm solving for still evaluates to 0, so ((a*b)=5,a) will still evaluate to [], because b is treated as 0. Would it be best to just wipe to software and start over at this point? Or is there something I'm doing wrong or something else to try?
The variables "a" and "b" are probably defined as user variables. Go to <Shift><Mem> and then tap User Variables, scroll down the list and delete the variables "a" and "b". After you do that, your CAS operations should work as expected, but your App may not.

Now that your screenshot is visible (to me, anyway), it is clear that you have the value 0 stored in both almost all your lowercase letter variables (on the screenshot) except for 'e' and 'g'. Check your memory browser to see if they are variables listed there and purge them.
Reference URL's