HP Forums

Full Version: HP Prime Connectivity on Linux-based Systems?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello everyone,

I have tried to research this topic in depth but I haven't found a solution that works. I am trying to upload files to my HP Prime from GalliumOS (Ubuntu 16.04-based). I have tried both libhpcalc and the official connectivity software + WINE, with varying success. With libhpcalc, only one of four programs I have tested out actually uploaded correctly, with the other 3 seeming to upload but only being 1KB large, and having just a few unknown symbols as the contents of the file. Running the setup for the official connectivity software yields a "Missing ACL" error, and it seems like it doesn't create the log file that it links to in the error message. I've tried to update the Windows version in winecfg, add vcredist2013 through winetricks, and install the vcredist through the official Microsoft installer. All three seem to have gone through without a hitch but the error message remains the same. I am a little surprised that HP hasn't implemented a solution for Linux users, but these other workarounds have seemed to work for others, so I am not sure about the issue on my end.Hopefully one of you guys can provide some insight.

Reference URL's